Unreal Engine 4 games showing white screen with 396.24.02 drivers

It seems like there’s a driver regression with the 396.24.02 drivers. All Unreal Engine 4 games seem to display a white screen. The games’ 2D menu elements will be displayed on top of that white screen. See this pic here: https://steamcommunity.com/sharedfiles/filedetails/?id=1398839457

I’ve tested this with Everspace and Ruiner.

Fedora 28 KDE
Kernel 4.16.13
Geforce 1070 with 396.24.02

I can confirm for Everspace.

Kernel 4.15.0-23-generic (Ubuntu)
GeForce GTX 980M with 396.24.02

Yes , it is same for me on 396.24.02

GTX 1050 4 GB mobile

I have the same problem, Ruiner, Ubuntu 18.04 LTS, drivers are from ubuntu graphics ppa

Confirming for Everspace, didn’t test with RUINER or Astrokill yet, but I guess it’s the same.

Also tried with __GL_NextGenCompiler=0, but it didn’t help.

RUINER also has the same issue , which is an Unreal Engine 4 title.

@sandipt @aplatner

Are you aware of this issue?

I can confirm this for RUINER and EVERSPACE with 396.24.02. While in RUINER the main menu still looks good, it went white when the actual game starts. In EVERSPACE however, it is already white in the main menu.

OS: Linux Mint 19 Tara
CPU: AMD Ryzen 7 1700
GPU: GeForce GTX 1080 (396.24.02)
RAM: 32 GB

Using vulkan instead of opengl fixes this.

Same issue with Spellsworn (UE4 OpenGL) with 396.24.02

works fine with 396.24.00

log with 396.24.02
https://pastebin.com/w5Wtiyha

log with 396.24.00
https://pastebin.com/HUpshNPV

Hi,

I do confirm the issue with 396.24.02 on EVERSPACE. We will soon be releasing a new build from the 396 main branch which won’t have that issue.

We are also about to release a new build from the side branch which will still have this issue, unfortunately.

Note that the side branch (e.g. 396.24.02) is meant for Vulkan developers and can potentially ship with OpenGL regressions such as that one.

thanks for the information. It’s nasty to switch between drivers when testing vulkan stuff and then wanting to play some opengl games, but i guess if there isn’t any other option then this is what we have to deal with.

The issue is still present with the 396.24.10 on EVERSPACE.

Is this version the “new build from the side branch which will still have this issue” you talked about?

Yes.

Seems to be fixed for EVERSPACE with 396.45.

Can confirm , issue with RUINER is also solved on 396.45

Just launched Everspace on 396.54.06 and the white screen issue is back, I also tried Ruiner and it’s affected too.

this can be worked around with

__GL_GlslUseCollapsedArrays=0 %command%

into the steam launch options. Works with the Culling. Same command helps with Unity games like Rust and Verdun that crash on loading with those drivers

That solved it right away, thanks :-)