USB-C monitor not detected with nvidia-driver-535 on Ubuntu 22.04

My laptop suddenly seems to be not recognised by the Dell monitors I’m using.
I tried 4 different USB-C cables that i know work for other purposes.
I did not update any software or changed any settings before this.
I did however update all software to try to mitigate the problem.
I’ve been using the nvidia-driver-535 for months now without any issues.
The fractional scaling trick some people seem to be able to do to get it working also does not work.
I will try the Noveau driver just to see if it works right now

Here is some debug output, and I will try to attach the nvidia-bug-report.sh output to this topic.

sudo lshw -class display

 *-display                 
       description: VGA compatible controller
       product: GA106M [GeForce RTX 3060 Mobile / Max-Q]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: /dev/fb0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=nvidia latency=0 mode=1920x1080 visual=truecolor xres=1920 yres=1080
       resources: iomemory:600-5ff iomemory:620-61f irq:168 memory:83000000-83ffffff memory:6000000000-61ffffffff memory:6200000000-6201ffffff ioport:3000(size=128) memory:84080000-840fffff
  *-display
       description: VGA compatible controller
       product: Alder Lake-P Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       logical name: /dev/fb0
       version: 0c
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=i915 latency=0 resolution=1920,1080
       resources: iomemory:620-61f iomemory:400-3ff irq:167 memory:6202000000-6202ffffff memory:4000000000-400fffffff ioport:4000(size=64) memory:c0000-dffff memory:4010000000-4016ffffff memory:4020000000-40ffffffff

sudo lspci|grep VGA

00:02.0 VGA compatible controller: Intel Corporation Alder Lake-P Integrated Graphics Controller (rev 0c)
01:00.0 VGA compatible controller: NVIDIA Corporation GA106M [GeForce RTX 3060 Mobile / Max-Q] (rev a1)

nvidia-smi

Thu Apr 25 09:50:05 2024       
+---------------------------------------------------------------------------------------+
| NVIDIA-SMI 535.171.04             Driver Version: 535.171.04   CUDA Version: 12.2     |
|-----------------------------------------+----------------------+----------------------+
| GPU  Name                 Persistence-M | Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp   Perf          Pwr:Usage/Cap |         Memory-Usage | GPU-Util  Compute M. |
|                                         |                      |               MIG M. |
|=========================================+======================+======================|
|   0  NVIDIA GeForce RTX 3060 ...    Off | 00000000:01:00.0 Off |                  N/A |
| N/A   44C    P8              17W /  80W |    607MiB /  6144MiB |      0%      Default |
|                                         |                      |                  N/A |
+-----------------------------------------+----------------------+----------------------+
                                                                                         
+---------------------------------------------------------------------------------------+
| Processes:                                                                            |
|  GPU   GI   CI        PID   Type   Process name                            GPU Memory |
|        ID   ID                                                             Usage      |
|=======================================================================================|
|    0   N/A  N/A      6149      G   /usr/lib/xorg/Xorg                          210MiB |
|    0   N/A  N/A      6612      G   /usr/bin/gnome-shell                         94MiB |
|    0   N/A  N/A     11752      G   ...onEnabled --variations-seed-version       95MiB |
|    0   N/A  N/A     12391      G   ...yOnDemand --variations-seed-version       62MiB |
|    0   N/A  N/A     14364      G   ...AAAAAAAIAAAAAAAAAA== --shared-files       40MiB |
|    0   N/A  N/A    179618      G   ...ictureAPI --variations-seed-version       91MiB |
+---------------------------------------------------------------------------------------+

uname -r
6.5.0-28-generic

sudo cat /sys/module/nvidia_drm/parameters/modeset
Y

Processing: nvidia-bug-report.log.gz…

The Noveau driver also seems to not work.

The upload seems stuck. Please try to unzip and upload.

1 Like

nvidia-bug-report.log (4.1 MB)

The USB-C connector is driven by the intel igpu, not the nvidia gpu. The i915 driver reports connection issues and crashes regularly:
80.085134] i915 0000:00:02.0: [drm] *ERROR* AUX USBC1/DDI TC1/PHY TC1: did not complete or timeout within 10ms (status 0xad40023f)
Don’t know whether this is a kernel/firmware issue or the connector is simply broken. You might want to try using the liquorix ppa to upgrade to latest kernel.

Thanks for the advice. I ran the liquorix install script.
I’m now on 6.8.7-2-liquorix-amd64
Still no input detected on the monitor.

I’ve decided to ask a question on Ask Ubuntu since this does not seem to be a Nvidia problem?

No, it’s not an nvidia issue. Since you wrote that hdmi also doesn’t work, please create a new nvidia-bug-report.log with your monitor connected to the hdmi port.

Somehow this problem went away after a few more restarts without any other specific actions taken.
So it’s solved, but not satisfyingly.