VLC Player Crashes in Jetson Nano - Segmentation Fault (Core Dumped)

Hello All,

I’m using a 4GB Jetson Nano Developer Kit. It is using Ubuntu 18.04 LTS os. I installed a vlc player to stream live video from my arducam usb camera(IMX219 B0292). Whenever I select /dev/video0 on my capturing device to stream from the camera, it crashes with following error:

  $vlc
VLC media player 3.0.8 Vetinari (revision 3.0.8-0-gf350b6b5a7)
[000000557324b580] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[000000557324ed80] main playlist: playlist is empty
Opening in BLOCKING MODE
Segmentation fault (core dumped)

I’m a newbie to the Jetson Nano development, any help to resolve the problem is appreciated.

You may try to disable OMXIL plugin.

Hello @Honey_Patouceul, I tried disabling the OMXIL plugin from the other solution. But It didn’t work for me.

Hi,
Please try this prebuilt lib:
Jetson/L4T/r32.5.x patches - eLinux.org
[camera] 3rdparty application fails to open with USB camera

If you require hardware encoding/decoding, we suggest try gstreamer or jetson_multimedia_api. We don’t enable hardware acceleration in VLC.

1 Like

Hey @DaneLLL, Thanks for the link. It worked. But my real-time streaming is blurry when I’m streaming with Vlc. What may be a reason for that?

Hi,
We suggest try gstreamer command and see if the issue is still present. Please refer to
Jetson Nano FAQ
[Q: I have a USB camera. How can I launch it on Jetson Nano?]