vnc setup question

Hello, so i was trying to set up a vnc server as given in this website https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-vnc-on-ubuntu-16-04#step-3-—-testing-the-vnc-desktop
I want to be able to remote desktop control my jetson tx2, but on that website on Step 3 they say to test the vnc desktop by using the command

ssh -L 5901:127.0.0.1:5901 -N -f -l username server_ip_address

i substituted the username with my boards username and the ip address with the boards ip address and left the rest of the command untouched. however i get the following:

bind: Address already in use
channel_setup_fwd_listener_tcpip: cannot listen to port: 5901
Could not request local forwarding.

does anyone know how to fix this?

the command looks like that, as it seems to me:

ssh -NfL 5901:127.0.0.1:5901 -p {ssh_port} user@server_ip_or_name

as quoted from http://pinnaman.com/posts/vnc-tips/

However, I’d rather use x2go or teamviewer.
Regards,

Thank you! I ran the code:

ssh -NfL 5901:127.0.0.1:5901 -p 22 nvidia@JETSON_IP_ADDRESS

and it only outputted a 0.

did you use x2go? I just downloaded it and installed it but once i get to the login and password for the jetson, i input the right information and it loads but then shows the message: “The connection with the remote server was shut down.
Please check the state of your network connection.”

“and it only outputted a 0” - what was expected to be the output?
The execution of the sequence does port configuration and set up, as it seems to me.
Once executed you could call 127.0.0.1:5901 e.g. from another terminal and that will throw to you 5901 from Jetson_IP-ADDRESS.
You can do that from vnc client as well. As far as I remember.

Yes, I am using x2go, thanks to my colleague who pointed me to it. It is very handy. However, while I used it as a server at Jetson TK1 I am rather using is as a client from Jetson TX2. There were some issues installing it as a server at 27.1 as far as I remember. I haven’t tried installing it at 28.1 as a server. I am using it from Jetson TX2 to deliver 64bit/32bit applications like teamviewer to Jetson. You may like to try it as well. I think a delivered from HostOS teamviewer should be sufficient to operate with Jetson , being delivered via x2g0. However I needn’t to test that yet. [In case Host OS runs 32_64 bit teamviewer and x2go server ,and tx2 uses x2go client and receives single application from the Host OS]
Once I test x2goserver at 28.1 - I will update you.
Regards,
Andrey

Thanks so much Andrey! I have a question, with the help of the x2go you can access the jetson and run graphical samples and see them right? if this is possible and you’ve tried it, can you please guide me through making this work?

"I have a question, with the help of the x2go you can access the jetson and run graphical samples and see them right? "

It seems that you want to use Jetson as a remote desktop server. Do not you?

I worked with TK1 as x2go server. TX2 returned some issues[with connecting to server side from outside] with 27.1. 28.1 was not tested yet by me as server.However, I am using it as a client.

You may like also to use Jetson as a remote desktop client which allows you to deliver applications to Jetson from 86 / 64 bit machines e.g from the host. E.g. I am running windows 7 under Jetson via virtualbox delivered via x2go.

I was able to do server x2go installation and connect successfully to Jetson TK1.
I haven’t tried doing so at 28.1.
As far as I remember there were some installation [server x2go] issues at 27.1.
However, [client x2go] works fine at 27.1 and 28.1, as it seems to me ,and can be used to deliver applications from HostOS to Jetson.

Basically, x2go is well described there: http://wiki.x2go.org/doku.php.

One more time : I haven’t tested x2go server with 28.1 yet.

It may turn out to work as a server or not.

27.1 used to have issues with server part of the application being installed to 27.1 Jetson.
However, if you are going to install server part to Host OS, I can assure you that clients part starts fine without any release for TK1, &, TX2 I worked with.
However, server part used to work fine with TK1.

Regards,

The problem is that you already have a server running on port 5901, and are trying to set up a second process to bind to the same port number. Chances are that you already have VNC running on your local host, which means SSH can’t bind to the same port to create a forwarding tunnel.

If you don’t have a firewall in the way, you don’t need the SSH forwarding tunnel anyway; you can just point your VNC client straight at the Jetson.

Another option, not using VNC, is simply to run an X server on your local machine, and start programs on the Jetson that point to your local machine X server. Typically, this is easier done with SSH forwarding tunnels, to avoid X authentication problems, but it should also be straightforward.

The main thing to keep straight is how networking works: What is an IP address, what is a port, and where do ports bind, and how do peers connect to ports? Also, how do SSH tunnels work? What’s the difference between a local and remote tunnel? And what’s the difference between the VNC model (server on the target machine, client on the viewing machine) and the X11 model (server on the viewing machine, client on the target machine) and how does that interact with the networking and the forwarding tunnels?
If you haven’t actually worked through those different concepts yet, I highly recommend finding a good resource that works for you to get them “down” in your active memory, because they are very important when working with more than one computer connected across a network.