When I run gst-launch-1.0 , system freezes and reboot

Hi,

I have a Jetson Nano Development Kit with the camera IMX219-77_Camera(IMX219-77 Camera - Waveshare Wiki) installed. Also, I installed the last jetson nano image in the system (jetson-nano-jp461-sd-card-image.zip)

When I look for the device, it is in /dev/video0, however when I try to run the following command:

DISPLAY=:0.0 gst-launch-1.0 nvarguscamerasrc ! ‘video/x-raw(memory:NVMM), width=3280, height=2464, format=(string)NV12, framerate=(fraction)20/1’ ! nvoverlaysink -e

System get freeze and after 10~20 seconds it reboots. I ran the above command with another terminal opened with the command: journalctl -f and I have been able to take a snapshot before it reboots.

Do you know how could I figure it out?

Hi,
Please check if you can run this command successfully:

$ gst-launch-1.0 nvarguscamerasrc ! nvoverlaysink

If it does not work, please contact the vendor to check the sensor driver.

Or you may try Raspberry Pi camera V2. It is supported by default.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.