2 Robot CANNOT Publishing Joint State Simutaneously


Hi all, there are 2 robots in my USD while their ActionGraph do not work as my expectation.
However, It works perfectly when there is only one.
Can you help me with it?

And here is the ActionGraph. Is there any mistake I’ve made?



I am willing to offer u more details only if needed.
thk u.

It might be the error showed in the console tab.

Now the Isaac Sim seems to be unable to recognise my joints type.
image

When I did this, e.g. from URDF importing to ActionGraph in old Release version, the Joint Type issue disappeared.
Hope it can be fixed soon if it is the version issue.
thks

Your action graph seems fine, but it’s hard to tell without looking at the details. Can you attach your USD file here if you feel comfortable? we can take a look

Thank you for reply.
I solved it in an early release version, e.g. 2022.2.1 but dont know why still.
The USD file is not supported for uploading, however.

BTW, it seems that the URDF file will be changed when I import the same file again while in another scene,thus destroying the old scene.
Can the issue be avoided?

Thank you again.

Hi, what do you mean by “the URDF file will be changed when I import the same file again while in another scene”? do you mean the stage is cleared? you can make sure you don’t clear the stage when importing URDF.

also, looking at the error from your earlier post, the “used mull prim” kind of looks like you didn’t actually specify the articulation root prim for the joint state node. Can you elaborate a little more about “not working as your expectation?”

@qwan
As shown in the pic, there are 2 robots in my Scene from my URDF file named walker, and they generated 2 folders and 2 USD files under the folder.
They worked correctly in my walker2_1114.usd file right now.
However, when I create a new Scene with the same URDF files, the old Scene doesn’t work then.
Perhaps the new scene covered the 2 USD files mentioned above.
image
And articulation root issue has been solved.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.