Accessing Jetson's terminal on Laptop using SSH

I want to access the terminal of Jetson on my laptop using SSH ,so I connected an Ethernet cable .Now the jetson and the laptop does not have an IP address so I have assigned one to jetson as and to my laptop as but, I have not assigned any default gateway.

what should be the default gateway ?

I am getting an error on Putty.

Normally DHCP assigns not just an address, but also a netmask. When you manually override DHCP you need to assign both address and netmask (and possible default route or gateway). When an address is used by an application on the computer which is not an exact match to the existing address (meaning the address is for a different computer outside of the current computer) the netmask is used to determine if that interface (that ethernet wire) is used to reach the address. Your netmask is probably wrong in combination with not having a gateway to forward to the address.

If netmask is wrong you could still assign a default route and gateway. A default route and gateway tell the system what interface to use if the combination of address and netmask for a particular interface does not show a working route.

Instead of telling you all of that, I’ll show you example files instead. Keep in mind that if you run NetworkManager, or if DHCP is still getting an address, that things might behave oddly and cause frustration (especially if WiFi thinks it should take over and disable wired). What follows assumes you do not use WiFi and that there is no DHCP request trying to override what you are doing.

If you use “ifconfig” the various interfaces will be named. I am assuming your wired ethernet shows up as eth0, but this might vary.

In “/etc/network/” I have edited “interfaces” to be like this:

# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d
<b>source interfaces.d/eth0</b>

Note that although the default of this file is to load everything from the “interfaces.d/” subdirectory that this might not actually happen (there is a mix of init script tools and not all tools work the same). This is why I added the line specific to “eth0”.

Within “/etc/network/interfaces.d/” I have added file “/etc/network/interfaces.d/eth0”. The following is an example to assign address

auto eth0
iface eth0 inet static

Netmask to use depends on the subnet. Here is a list of private networks (ones used by internal LANs, not used or routed by the real internet), and I assume your address is in one of these:

So for example if your assigned address had instead been instead of, then the netmask would have been, which is an alternate way to say “”. A list of the alternate ways to figure out netmask is here:

About gateways, see:

The gateway is the address of the computer which will forward any request your network/netmask combination won’t work with directly. In that example ping to would be part of the existing machine, and thus would directly ping itself. The address could be another computer sitting next to the Jetson, and ping of would work by going through eth0 because the combination of address and netmask are valid. This same computer, if trying to ping (an address) would fail within the address/netmask, and so the default route would attempt to go to the gateway for further routing…in this case the router is The reason I have as gateway is because this is my host PC and the host PC has address forwarding enabled.

A more typical gateway would still name the eth0 interface, but use a netmask of The reason for this is that a gateway tends mean “anything the specific network/netmask combinations don’t cover”, and the “” netmask implies a general broadcast (a plea for help from anyone who will answer).