AGX Orin doesn't boot after l4t update to 35.4.1

I tried to update r34.1.1 to r35.4.1

After reboot AGX orin stuck in L4TLauncher on EFI stub: Exiting boot services and installing virtual address map …

I can’t access AGX orin by

  1. ethernet
  2. USB-C
  3. microUSB
  4. keyboard respond in first seconds (numlock), but after stopping of a fan it doesn’t respond

What can I do to reset agx orin?


Are you using a DevKit or a custom board?
How did you update it?

There should be serial console log being output from the micro USB cable.
Check /dev/ttyACM0 on your host PC with tools like minicom or picocom.

Hi DaveYYY, it is a devkit.

I modified

and ran

sudo apt update
sudo apt dist-upgrade
sudo reboot

Can you please check this?

I tried to connect with microUSB but there was no


files created.

After you power on the device?
Then I can only suggest re-flashing the device:

Yes the device is powered.
LED is white.

I didn’t see a board as a USB device so SDK manager didn’t detect it.
I tried to put device into force-recovery button reset + button force-recovery.
I tried multiple times, and it finally worked only now.

I will try to reflash and return with results.

1 Like
  1. Just a reminder that /dev/ttyACM* is on your host PC

  2. Another reminder that you have to use type C port on the opposite of the power jack to flash.
    Only this type C can be used for flash.

Yes, I check for dev/tty on host machine connected by both USB-C for flashing and microUsb.

I managed to flash but after rebooting: boot proceeds further, I see IP of my AGX orin in the network.

But it doesn’t boot to OEM process and dev/ttyACM* are not created on a host machine.

I will try to reflash one more time.


If you are sure the IP is there on Orin AGX but micro usb port cannot give you /dev/ttyACM* on your host, then you should check the cable or log on your host.

A IP is only present when you boot into jetson.

If cable does not have data line (cheap power cable), then it won’t be able to dump log.

I reflashed one more time, and this time GUI for OEM was displayed without issues and I was able to proceed with installation.

Yes, I think the problem with MicroUSB was with the cable itself.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.