AGX Xavier Developer Kit start up problem


I am using AGX Xavier Dev. Kit with a laptop adapter which is 19V, 3.42A and 65W. First time, there was no problem. After that HDMI signal was not running correctly. But now, dev. kit does not start anymore. When I press the power button the white led blink and it powers off.

Is the problem because of the adapter ?
Was dev kit damaged ?

The dev kit power adapter is rather reliable, but in other cases of different power supplies the Xavier can be picky about regulation right at the instant of powering on. It sounds like your power adapter is not the one which comes with the dev kit, and so under the circumstances I do suspect it is a power supply issue (though not necessarily). Can we confirm this is a dev kit, and that the power supply is not the default dev kit supply?

Some typical cases where there might be a power delivery issue despite no hardware failure:

  • Power supply itself does not regulate well during initial power spike requirements,
  • Power cables are longer, introducing resistance (tiny amounts of resistance matter).
  • Power cables are lower gauge (also introduces tiny amounts of resistance, and this matters).
  • Power connector is slightly wrong in size. There are many connectors advertised as “5.5mm” outer diameter, but inner diameter may actually be either “2.5mm” or “2.2mm”. Some with the wrong inner diameter don’t have problems in most cases, but for supply of a Jetson, tiny resistances matter and the connector itself may be unreliable for a Jetson.

In many cases where resistance is a problem adding a high value capacitor (perhaps over 2000uF) right at the connector can help.

In cases of actual hardware failure the failure is almost always due to a failure on the carrier board, whereas the module normally does not fail.

Hi again,

Yes this is a dev kit and the power supply is not the default dev kit supply.
Power supply is 19V, 3.42A and 65W and connector’s diameter is 5.5mm outer and 2.5mm inner. I used the dev kit about 30 minutes with this adapter without any problem. .
When HDMI problem occurs, I plugged in and plugged out hdmi cable more than one. After that I power off dev kit via power button. When I try to power on it didn’t power on. But when I press the power button, power led blinks.

How can I understand that there is a hardware problem ?
If I reflash the dev kit, can problem be solved ?
Thank you for your help.

Can you try the power supply which comes with the dev kit? If this works, then it is probably a problem of the other power supply. If the supplied dev kit fails in the same way, then I suspect a problem in the hardware of the carrier board.

NOTE: Flashing again won’t fix a power LED showing power off right after power on.

I lost the power adapter which is supplied with dev kit.

Could the problem be caused by HDMI cable?
How can I find the hardware problem ?

If this board is not even powering up, then issue is not related to HDMI cable… You should RMA your board.

Also, why no just connect this HDMI cable to other source to see if this cable still works?

I connected the HDMI cable other source. HDMI does not work, so I asked that could device be damaged because of HDMI cable ?

You should clarify whether the board is powering up or not first.
I don’t think a bad HDMI cable will crash the board…

HDMI will have no effect on power going down.

For clarification, the unit is using a different power supply. The unit had worked for about a week. Indications now are that upon attempting to start the power supply is not able to provide sufficient regulation and is just shutting down.

Yes that is true but not actually a week.
Anymore, when I press the power button, only power led light on a second and powers off. There is no power on peripheral devices. I tried with different power supply which is 19V, 90W and not supplied with dev kit . Situation is same.
I measured the outputs of adapters with multimeter. One of them is 19.5V and the other one is 19V. So, I don’t think that dev kit is damaged by power supply.

Hi goksungur,

Ok, let’s forget about HDMI cable. There is no need to track which one damaged your board at this moment.

Do you see the LED blinked when you press the power button now?

Hi Wayne,

Yes, when I press the power button, the LED light on for a second and powers off.

Ok, then please RMA your device.

1 Like