All objects are transparent in Blender VR mode using OpenXR for AR

I have been using Blender VR to view 3D models on OpenXR. I am using AR on the sample Android client.

I had 2 questions:

1) All objects are semi-transparent. How can I make it appear fully solid? I suspect there is some issue around alpha channels and rendering on both left and right views, but I don’t know how to resolve this.
2) The 3D objects I render are frequently too large. It is a matter of trial and error for me to figure out how small I should resize my assets. Is there a reference for which I should be scaling my 3D models against?

Thank you.

On further investigation, I have found that parts of the model which are directly lit in the viewport by a light source are rendered. It seems that unlit parts of the 3D model are treated as having an alpha value of 0 in AR mode, so it looks transparent.

I am still unsure how to make the full object visible.

I could not resolve this issue. However, I have found that using Unity’s built-in OpenXR view mode inside the editor is a much more robust experience and does not have the alpha channel issue.

  1. sounds like you have a solution with Unity. I don’t know blender offhand, but it certainly sounds like unlit objects have alpha incorrectly set. Maybe try a low ambient light in addition to direct light sources?

  2. I think overall scale is in meters (or mm), but as the sample controls the projection and view you should be able to adjust as needed.

The transparency issue happens in Unreal Engine too in my case. I tried different options but nothing corrects it. Any idea why it happens or how to make it work in Unreal ?..