All USB ports stop responding when USB Modem is connected/disconnected from Jetson Orin Nano

I’m trying to use a USB gsm modem, the Waveshare SIM7600G-H 4G HAT (B), with my Jetson Orin Nano running Ubuntu 20.04 via the Jetpack 5.1.2 image. However periodically when it’s plugged in, all my my USB ports stop working, disconnecting my mouse, keyboard, and the modem itself. The only fix when this happens seems to be to reboot the Jetson entirely, but the issue always comes back when using the modem.

I can consistently replicate the issue by unplugging the modem while connected to 4G, but it also seems to happen randomly when I haven’t touched the modem. One thought I had was that the USB Autosuspend feature was shutting off the modem automatically, so I tried blacklisting the device from autosuspend using TLP. Unfortunately, this didn’t do anything to help.

I get the following in my logs when it happens, looks like the USB controller dies inexplicably

[ 590.845918] tegra-xusb 3610000.xhci: controller error detected
[ 590.851964] tegra-xusb 3610000.xhci: hcd_reinit is disabled or in progress
[ 595.923801] tegra-xusb 3610000.xhci: xHCI host not responding to stop endpoint command.
[ 595.932077] tegra-xusb 3610000.xhci: USBSTS: 0x00001001 HCHalted HCE
[ 595.938633] tegra-xusb 3610000.xhci: xHCI host controller not responding, assume dead
[ 595.946752] tegra-xusb 3610000.xhci: HC died; cleaning up
[ 595.952381] tegra-xusb 3610000.xhci: hcd_reinit is disabled or in progress

Any suggestions or ideas for what might be causing this?


Please connect the device to a USB hub with external power supply and then connect to Orin Nano. To confirm if the issue is present if there is external power supply. Sometimes we hit stability issue if power supply is not stable enough.

Powered the modem using an external power supply and haven’t encountered the problem in regular use. Looks like there was power issue, thank you for the help!

However, I tried unplugging the modem while connected to 4G mobile broadband to test and it still kills my USB ports. It won’t be a problem for me going forward, but is this a known issue?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.