Audio2Face hangs during save

I initially loaded an exported facial mesh from Character Creator 4 and got it all working as expected in A2F. When attempting to save my work in A2F, it hangs on “saving levels”. I’m not explicitly using levels, as far as I know.

I’d appreciate any help.

hi there, could you share your file so we can investigate?

What would you like me to share, as I can’t save from A2F?

The original file from Character Creator 4 should be good for testing.

I just tried it with the standard Camila character from CC4 and it also hangs. I simply exported her out of CC4, using the Omniverse plugin, selected the A2F mesh option, and loaded the resulting USD into A2F. Without doing anything more, I tried to save and it hung. I’m not sure that I’m allowed to upload the USD here, due to licensing.

could you please share your log file?

You can find the log files here: C:\Users\<USERNAME>\.nvidia-omniverse\logs\Kit\Audio2Face

Please see attached logs. Thanks! (753.7 KB)

FYI - I tried saving with the “save flattened as” option instead of the normal “save as” and then it didn’t hang. However, when I tried to open the resulting saved usd, it hangs then.

Thanks for providing the log.

  • Are you able to save other scenes in A2F? eg, saving the default scene that opens when starting A2F.
  • Are you able to save this problematic scene at first, but it stops saving after a certain stage?

I just found the source of the problem. I have been trying to save into the local server (Omniverse/localhost). When I just tried with a normal local folder, it saved and loaded fine. I’ve saved into the localhost location before, so I’m not sure what’s going on with that. Also, even though it hangs when saving into localhost, it does appear to save a file. I just can’t open it.

As long as I can save it elsewhere it’s not a big deal for me.

Thanks for posting your solution.

This is a bug where the app hangs when we try to save on the root. The workaround is to save in a subfolder for now.

This doesn’t work: omniverse://localhost/file.usd.
This works: omniverse://localhost/folder/file.usd

This will be fixed in the future releases.