Black screen after install of nvidia driver ubuntu

Please create a new nvidia-bug-report.log.

I tried to access the terminal but unfortunately, all I see is a black screen right now and it’s not responding after I pressed Ctrl+Alt+F1/F6/F7 several times. Do you have any idea how to access the terminal and generate the bug-report?

Update: I tried to access the terminal from recovery mode, but it’s not responding there. The only output on the screen is :

Loading ubuntu 5.x.xx-generic…
Loading initial ramdisk…

You might try pressing alt+printscreen+r and afterwards alt+f4
If that does not work, boot to recovery mode and create the log from there.

Whenever I click the app I get a small window and my only options are help or quite (which are clickable). otherwise the screen is completely black and nothing can be clicked inside it. I have attached the nvidia-bug-report and would you like to look over it?
nvidia-bug-report.log.gz (675.5 KB)

I’m also facing the black screen issue. I have a two screen setup including my laptop builtin display. When I run nvidia-xconfig, it creates the xorg.conf file but only detects the external HDMI monitor. After a reboot, only this on works fine, the builtin one only shows black screen. I also detached the bug report. Would be great if anyone would help me. Tried to fix it for so many hours now.
nvidia-bug-report.log.gz (256.2 KB)

I installed drivers from ubuntu additional drivers.I also have the same issue. ubuntu gets stuck at boot screen at ubuntu logo. so I purged Nvidia drivers at a login terminal. the same issue continues. please help me booting Ubuntu with Nvidia. also, I don’t think I have messed up with any defaults.
here is my log file, please help
nvidia-bug-report.log (255.2 KB)

please help

Hello I have recently encountered the same issue. None of the solutions above seems to be working. The black screen for (k)ubuntu starting appeared after linux kernel+nvidia drivers update, but switching back to any of the previous versions does not resolve the issue.
Kubuntu 18.04, GeForce GTX 1070, ASUS Strix GL502V.
nvidia-bug-report.log.gz (261.9 KB)

Thanks for any help!


I think I have the same problem as rest of the people here. I have stationary PC. GPU is 1080ti, Intel 8700k CPU. MB is AsRock Z370 Extreme4. Fresh Ubuntu 21.04 installation with Win-Linux dual-boot setup.

After installation I can restart the Linux environment as many times as I want. But the resolution is ultra-low (1024x). So I update the Nvidia drivers from PPA (tried versions 450 and 460).

  • When restarting the PC soon after nvidia driver installation - PC just freezes and therefore won’t restart.
  • After system hard switch-off and ON - PC proceeds with boot process as normally, shows the GRUB window, then tries loading the Ubuntu (which is selected as default system) and… freezes. All I see is the Asrock logo in the middle of a black window. No console, no cursor, no log messages.

nomodeset and nouveau.modeset=0 do only 1 difference. Instead of seeing the Asrock logo - PC shows a completely black window with no cursor or logs. And seemingly freezes/does nothing.

With some trial and error I have managed to connect to PC via SSH when kernel is run with parameters nomodeset noefi noacpi noapci - some of these parameters seems to have helped. The system is still not booted but I can SSH into it. And I see some logs and a console. Also at this point I also managed to CTRL+ALT+F2. (I think it was when I installed sddm as default desktop manager) but the problem persists.

When connected via SSH - I tried running the (also with flags) command but it never finishes executing so I cannot provide you with the log file. When I type “top” command to see the running processes I can see that there is 1 process that eats up 100% of CPU at all times: kworker/9:1+rcu_gp. Is this helpful?

I have already reinstalled the Ubuntu system 4 times because of this issue… Please help. I am ready to provide all the information I can in order to make it work…

p.s. In BIOS: secure boot disabled, fast boot disabled. Dedicated GPU selected as default. BIOS is of latest version.

Fresh Ubuntu 20.04 install:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install openssh-server
sudo apt-get install lightdm
sudo dpkg-reconfigure lightdm
sudo apt-get remove nvidia*
sudo apt-get remove nvidia-*


echo “blacklist nouveau” | sudo tee -a /etc/modprobe.d/blacklist-nouveau.conf
echo “blacklist lbm-nouveau” | sudo tee -a /etc/modprobe.d/blacklist-nouveau.conf
echo “options nouveau modeset=0” | sudo tee -a /etc/modprobe.d/blacklist-nouveau.conf
echo “alias nouveau off” | sudo tee -a /etc/modprobe.d/blacklist-nouveau.conf
echo “alias lbm-nouveau off” | sudo tee -a /etc/modprobe.d/blacklist-nouveau.conf
echo “blacklist nouveau” | sudo tee -a /etc/modprobe.d/blacklist.conf
echo “blacklist nvidiafb” | sudo tee -a /etc/modprobe.d/blacklist.conf
echo “options nouveau modeset=0” | sudo tee -a /etc/modprobe.d/nouveau-kms.conf
echo “blacklist nvidiafb” | sudo tee -a /etc/modprobe.d/blacklist-nvidiafb.conf
sudo bash -c “echo blacklist nouveau > /etc/modprobe.d/blacklist-nvidia-nouveau.conf”
sudo bash -c “echo options nouveau modeset=0 >> /etc/modprobe.d/blacklist-nvidia-nouveau.conf”
sudo depmod -ae
sudo update-initramfs -u


sudo apt-get install dkms build-essential linux-headers-$(uname -r)
sudo service lightdm stop
sudo apt-get install nvidia-driver-460
sudo apt install nvidia-prime
sudo prime-select nvidia

verify no entries:

grep blacklist /etc/modprobe.d/* | grep nvidia
grep blacklist /lib/modprobe.d/* | grep nvidia

  • reboot (regular reboot - stuck at AsRock window. No SSH possibilities)
  • reboot (with nomodeset - black screen, but with shell console log-on option available in WinSCP client. SSH logon in putty freezes after entering password)

now, while in this black screen mode, and with console terminal opened on another PC in WinSCP. Here is diagnostics data.

lshw -c video

description: VGA compatible controller
product: GP102 [GeForce GTX 1080 Ti]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:163 memory:de000000-deffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:c0000-dffff

lsmod | grep nvidia

nvidia_uvm 1011712 0
nvidia_drm 57344 0
nvidia_modeset 1228800 1 nvidia_drm
nvidia 34136064 8 nvidia_uvm,nvidia_modeset
drm_kms_helper 217088 1 nvidia_drm
drm 552960 3 drm_kms_helper,nvidia_drm

modprobe nvidia
nothing returned

cd /usr/share/X11/xorg.conf.d/ && ls


cat 10-nvidia.conf

Section “OutputClass”
Identifier “nvidia”
MatchDriver “nvidia-drm”
Driver “nvidia”
Option “AllowEmptyInitialConfiguration”
ModulePath “/usr/lib/x86_64-linux-gnu/nvidia/xorg”

cd ~ or cd /tmp
Seems like at this point system is in read-only mode…

ERROR: Working directory is not writable; please cd to a directory
where you have write permission so that the nvidia-bug-report.log.gz
file can be written.

cd /dev

The tool DOES run in /dev folder, but it aborts my remote session for some reason. So I never see the tool finishing executing! However, it DOES produce report files… Though, only 2kb in size

reboot into recovery mode. Enable networking. Open root console.

rm /run/nologin
systemctl restart ssh
cd ~ –safe-mode --extra-system-data

Without –safe-mode --extra-system-data attributes - command hanged/freezed the PC on first try… On second try - with attributes - command actually finished with no problems.

So, long story short - I have the same problem as before. Completely black screen, with no cursor or any means of iteraction (when booted with nomodeset). Without nomodeset same situation, but asrock logo shown.


  • 0attributes_crash_nvidia-bug-report.log.gz - (freeze)
  • 1attributeSafeMode_nvidia-bug-report.log.gz - –safe-mode (no freeze)
  • nvidia-bug-report.log.gz - –safe-mode --extra-system-data (no freeze)

p.s. After studying logs - I realized that PC freezes due to failure in nvidia-smi command in bug report script… I have verified this behavior couple of times, when I tried running nvidia-smi command manually.

dmesg_tail500_oneOfEarlierBoots_withError.txt (41.5 KB)
dmesg_tail500_latest_noError.txt (39.3 KB)
0attributes_crash_nvidia-bug-report.log.gz (79.7 KB)
1attributeSafeMode_nvidia-bug-report.log.gz (79.9 KB)
nvidia-bug-report.log.gz (79.8 KB)

nvidia-bug-report.log (1.6 MB)
info.txt (9.4 KB)
Xorg.1.log (36.0 KB)
journalctl.txt (390.7 KB)

I am experiencing something similar: black screen after login when just installed the driver v. 465 several times. nothing seems to work. my gpu is 3090 geforce RTX. I have no problem with Windows.

Same Problem here. Linux Mint 20.1 dualboot with Windows. After installing the 460 driver i am stuck at the loading screen of my mainboard.

At least i was able to load an older kernel and enter linux in low-res. And thank good i have Timeshift configured!

I kind of solved this by installing the driver using ssh from my laptop. I had to shut down the X-Server before launching the .run file.

I solved it like this:
[Possible SOLUTION ! for Black Screen UBUNTU and latest 460 driver!]

guys possible solution for this until they solve this is to do sudo prime-select intel
do this during boot terminal which will keep Nvidia drivers & also boot (every time)
also, I have noticed on demand & performance modes are the reason for this boot problem
and Nvidia when are u going to make our GPUs usable


When I first got this problem I was running ubuntu 20.04 (2 weeks ago). I got stuck at the boot logo … just after a kernel and driver upgrade.
I have not been able to fix it in any way. I tried to re-install ubuntu 20.04, upgrade to 21.04 but nothing - I then decided to go for ubuntu 20.10, installed from a clean HD (yes NVIDIA, you made me do a complete backup of my files and reinstallation of my whole system!) and … yes it worked … but only for 10 days, until I decided to run again a dist-upgrade (which is pretty much needed on as un-released distro)
After the upgrade, I got stuck again at boot … again!

After weeks now! I was following other threads … struggling with the same issue, this discussion helped me in isolating the issue.
The problem, at least for me, is with the proprietary drivers and the Monitor.

My settings:
dual 34’’ monitors

  • dell U34
  • lenovo think vision
    NVIDIA GTX 1070

Both monitors connected via DP - no boot (stuck at the boot logo)
Unplugging the dell I can boot and the system loads the NVIDIA driver (nvidia-smi shows the GPU and I can import/use cuda stuff in python)

Plugging in the dell (via DP) while the system is running ends up in a terrifying OS freeze.
I do not have a cable to test the DELL via HDMI at the moment, I’ll report later if that will work.

It does work with HDMI

Geforce RTX 2060 super. Tried installing Ubuntu 20.04. I get a black screen with a frozen cursor in the top left. I tried purging all nvidia drivers and installing the latest available driver, apt install nvidia-driver-465. I ran but it froze, so I ran it in safe mode and attached the log. I would appreciate assistance @generix
nvidia-bug-report.log.gz (81.9 KB)

I have the same problem with my new Alienware M17 R4
GeForce RTX 3080 Laptop GPU
VBIOS Version:

BUT: the screen is not really totally black. Only backlight is not working properly (you see a shimmering login screen).

My way to solve it was to install a specific driver version:

After fresh installation of Ubuntu 20.04: Strg+Win+2 → Terminal → Uninstal Nvidia Driver → Install Nvidia Driver 460.67 → Deactivate “Nouvaue”

But this is not perfect. I did not try CudNN and Tensorflow with GPU Support and hope, that this will work in the future.

I have a GeForce GTX1050 Ti (Ubuntu 20.04.2 LTS)
GeForce GTX 1050 Ti/PCIe/SSE2 / NVIDIA Corporation GP107 [GeForce GTX 1050 Ti]

On a fresh ubuntu installation it works fine but after an apt update my both screens turns dead black, nothing. And the behaviour is the same on two computers with 1050 GTX boards running the same Ubuntu version.
I found that changing back the driver to 450 driver from the 460 driver works.

Just wanted to report back on the issue. After trying out and failing to use the Ubuntu of different versions - I have decided to try Debian and… it worked. No driver issues for far.

Note: you have to install the driver form buster-backports in order to get latest up to date version.

Instructions here: NvidiaGraphicsDrivers - Debian Wiki