Board dosen't power-on,

When I connected power adaptor to jetson board, pwr led doesn’t on and display doesn’t work.
I have another jetson board which is same model. So I connected the same power adapter and it worked.
So it doesn’t seem to be a power adaptor problem, but a problem with the board itself.
How can i fix it? (4.0 MB)

Have you try to flash the SW on your Jetson Orin devkit?

Previously, I entered recovery mode using a jumper and installed Linux on the board several times.
I was using it well, but one day I connected the power cable and tried to boot, and the situation was the same as now.
Afterwards, I tried to reinstall it using sdkmanager as shown in the attached photo, but the board was not recognized by the host computer.

Not detected with jumper, flash cable, and power cable connected?
Are you able to get anything from serial console?

As shown in the attached photo, I connected the power cable - board - to the host computer and tried to enter recovery mode using jumper wires following the guide, but there was no response.
When I connected the power cable, the only response was that the LAN LED briefly turned on and off.
There was no TxRx to usb cable, so I tried serial communication with minicom by connecting it with a USB type C cable, but it was not recognized by the host computer. When I tried the same method with another orin nano I have, communication was smooth. Would it be meaningful to purchase a TxRx to USB port and try communication?

You can only get serial console with a TTL-USB cable, not a USB-C cable, which is used for flashing.

As you answered, I tried to access the serial console using the TTL-USB cable. It was impossible as shown in the attached picture. I think the power is not applied to the board. What do you think?

It still showed nothing after power on without a jumper?
Then maybe you need to RMA it?

As shown in the video attached to the first question, when only the power adapter is connected without a jumper, there is no change other than the LED on the LAN port turning on for a few seconds and then turning off. Even if I try connecting it to the DP port, the monitor still doesn’t recognize it.
If I do an RMA, what are the related procedures?

Please check this link:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.