Can Bus Implementation on Jetson Nano

I have tried to use a CAN BUS shield with a Jetson NANO using follow the steps mentioned in the below post-

I am using a Jetson Nano Developer Board (2GB) and I have tried using the Sparkfun CAN Bus Shield and seeedstudio CAN Bus Shield. The Connections done with both the boards are as mentioned in the Unofficial guide.

I followed Steps 1 to 5 which did not work
After I ran this command - > sudo /opt/nvidia/jetson-io/
I opened the pin layout which I configured for MCP251x and rebooted but after that can bus commands did not work.


I used this command in /kernel/kernel-4.9 to build the kernel
> ./

After that I copied the mcp251x.ko file to /lib/modules/4.9.253-tegra/kernel/drivers/net/can/spi

But after that when I ran the command
insmod /lib/modules/4.9.253-tegra/kernel/drivers/net/can/spi

I am getting the following error-

The driver file is not able to load. I have used >dmesg | grep spi command but I am getting output like below

What could be the possible reason for this? Can you also confirm if I can use the Sparkfun CAN shield and Seeedstudio CAN shield with the Jetson, because in the unofficial guide MCP251x module has been used, however both Sparkfun CAN shield/Seeedstudio Can shield has MCP2515 module present in them. I have pasted the links to both the CAN shields below.


Please check below topic to see if can help: CAN with Jetson Nano Production Module

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.