Cannot flash Jetson AGX Orin


I’ve tried to follow the guide to reflash the Jetson from but I cannot get the Jetson into recovery mode. I tried the button approach and the command approach with “sudo reboot forced-recovery”.

I’ve attached the minicom logs from trying the software approach. You can see in line 1594 that what happens after I entered the command.
cmd-serial.log (166.7 KB)

This log is from trying the button method:
buttons-serial.log (83.1 KB)

Kind regards
Yunus Ayar


Are you saying that recovery mode is even not able to work even with button?

Yes, I tried with the Jetson powered off: holding recovery button (middle one of the three buttons) → power button press → releasing recovery button

and with the Jetson powered on: holding recovery button → reset button press → releasing recovery button

But I noticed a normal boot takes around 45s and one with the button method around 90s. I still cannot flash anything even when running sudo ./ ${BOARD} mmcblk0p1 continuously in a loop. The output of lsusb is always:

Are you sure this is NV devkit? I see some abnormal error in your log.

Thanks for your reply. I’m sorry, I don’t know what the NV devkit is. When I run jetson_release is says:

Also on the inner wall in the bottom of Jetson Cube where the serial number is printed it also says “Jetson AGX Orin Developer Kit”.

Maybe try holding the reset (not the power button) button longer, like so:
(While power is connected)
• press reset & recovery buttons together
• release reset button
• release the recovery button after 3 seconds later.

Unfortunately that does not work either for me.

The “abnormal” is probably the screenshot device with ID 0955:7045. What creates that ID? An AGX Orin would show up as 0955:7023. The manufacturer ID is correct, but the product ID is something else.

If you think the device is in recovery mode, e.g., you held down recovery, then powered it on, followed by releasing the recovery button, what shows up on the host PC upon plugin? You could monitor “dmesg --follow” on the host PC, and then watch what new log lines appear as a result of plugging in the USB. It’d be the USB-C to the right of the 40-pin header.

NV developer kit will be like this.

There are also some other vendors provide their own carrier board which we call it custom board.

Visually it looks the same as the one I have. But my specs are not listed on the official website

I have 32 GB total ram:

A 12 core CPU:

And a max GPU frequency of 1.3 GHz:

I tried connecting the USB-C (next to the 40-pin header) port as well the micro USB and it went into recovery. The output of lsusb:

Maybe the documentation needs to be updated?

Your module is this kind.

Just a reminder that the document has different version too.

Thanks for all the help!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.