Cannot set up CUDA toolkit for Quadro FX 3800 under win7

Hi!

I’m trying to install the CUDA toolkit 4.0 for a Quadro FX 3800 under windows 7 64 bits . Drivers installation, software and SDK went good. But when I tried to execute the bandwidthTest it says:

Running on…

cudaGetDeviceProperties returned 38
-> no CUDA-capable device is detected
[bandwidthTest] test results…
FAILED

Then I tried to change to TCC following the instructions in this forum but I get this message from nvidia-smi:

C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi -g 0 -fdm 1
Unable to set driver model for GPU 0:3:0: N/A

Can anybody help me?

Thank you in advance!

Have you installed a CUDA driver?

Yes, I have. Did it, uninstalled, restart, reinstall, restart… and still doesn’t work.

Hello Paquita,

Unfortunately I don’t know why you can’t run CUDA on your machine, but I can shed some light on the other problem that you had with TCC and nvidia-smi.
Quadro FX 3800 is based on GT200 chip and TCC mode unfortunately isn’t supported on this card.

Regards,
Przemyslaw