Can't setup CUDA-drivers on my GF-860M

Hello!
I have Acer Aspire Nitro VN7-591G-74AU
Intel Core i7-4710HQ
nVidia GeForce GTX 860M, 2 GB Maxwell.
I want use my GPU in Sony Vegas 13, but it says “do not have access to the GPU”. Sony Vegas requires supporting OpenCL or CUDA by GPU to use it in rendering. So specs in 860m have to be ok:
https://developer.nvidia.com/cuda-gpus
http://www.nvidia.ru/object/geforce-gtx-800m-graphics-cards-ru.html#pdpContent=2

The program, called TechPowerUp GPU-Z tells that my GPU supports CUDA and OpenCL, but sometimes the tick near the CUDA supporting disappears…!

When I try to setup “CUDA 6.5 Production Release” (https://developer.nvidia.com/cuda-downloads), it says something like “This graphics driver could not find compatible graphics hardware… you will not be able to run CUDA applications.”

What should I do ??? HELP HELP HELP !!!

Study this thread:

https://devtalk.nvidia.com/default/topic/782814/cuda-setup-and-installation/installation-problems-on-new-msi-gs70-w-970m-gpu/

The CUDA 6.5 installer does not have a driver that is usable with your 860M.

So leave the original 860M driver intact.

Deselect the option in the CUDA 6.5 installer to install the driver.

txbob, thank you! I did as you said.
But Sony Vegas still says “do not have access to the GPU”.

Is there another way to check supporting CUDA on my system after re-installing CUDA 6.5?

You can validate that your CUDA install is working correctly by following the instructions in the getting started guide:

http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-microsoft-windows/index.html#abstract

The usual suggestion is to make sure you can run some CUDA sample codes correctly, as discussed in section 2.5

I don’t know anything about Sony Vegas

txbob
I’ve just tested my system in that way. And PASSed all tests)
Now I think there problems in other programs, but not in my GPU…

Thank you very much!

Hi all,

I have the same issue, but cannot pass it by what just deselecting the option.

Hi have a GF-860 M as well, and try to install Cuda 6.5.

I get the “This graphics driver could not find compatible graphics hardware… you will not be able to run CUDA applications.” warning on install.

Later on, I de-select the option to install the driver, as you said.

But when I try to run the deviceQuery for example, I get
cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL

If I try to update my Driver by Windows Manager, it does not find any more recent driver.
I installed GeForce Experience Software, it detects my GeForce 860 M with its 333.37 driver, and says it is up to date.
I also tried to run the 347.25-notebook-…-international-whql driver from
http://www.nvidia.com/download/driverResults.aspx/81392/en-us
But when I run it it fails, by saying that it did not find any compatible hardware.

Any idea ?

Thank you very much.

You need a 340.xx or newer GPU driver to run CUDA 6.5.

The 347.25 driver you linked should be the correct one to use for your GPU. You might also want to see if your notebook manufacturer has published a 340.xx or newer graphics driver for your notebook.