Connec to ROS-master on Another PC

I am working on the ROS and run into an issue now.
After connecting to external ROS-master on another PC, parts of the Action Graph disappeared.
As is shown below.


In this way, I could not get the ROS topic JointCommand and JointStates from ROS-master.

In my .bashrc file, I added the codes as followed.
export ROS_IP=115.156.168.xxx
export ROS_MASTER_URI=http://***-Dell:11311

What can I do to solve it?

Here’s the method I’ve tried but in vain

I got the same error sometimes, try using file->reopen, for me it fixed the issue

@parmeggiani.alessio1 thk u for answering.
In my job, I imported the URDF and then added the Action Graph about ROS.
I reloaded the USD file but it didn’t work.
Do you mean rewriting the whole file or some other way?

I solved it by rebuilding the whole Action Graph.
It seems to be the problems about the newly Release version 2023.1.
However, it should not be a problem caused by update in the Omniverse Engine.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.