Connecting to CloudXR Server, VR Headset stays blind

I just started looking into CloudXR.
I created myself a virtual server hosting CloudXR.

With my PC I can connect to it, I can see that the movement of the VR-Headset is received by the Server, also I saw the controler movement.

But on client side the VR-Headset stays blind (I see a green or gray screen), I won’t see the scene which runs on the server.

I digged deeper into it and the live view from the server has already the “green screen”.

When I use SteamVR to create a Sreenshot (screenshot_all_request) on the server I receive three screenshots, “l” and “r”, which show the scene and “layer” whichs shows the green image.

I use on server and client NVidia driver 452.96.
My server VM is hosted on vSphere 6.7.

Any idea what could cause this behavior, or a hint what I can try to fix it?


I missed the notice about not using RemoteDesktop, now I switched managing my server with VNC and everythink works out fine.


Damn, exact same problem, glad you shared the screenshot I instantly saw that because inputs worked but not display. Disconnecting from remote desktop solved it.

1 Like

Great that my failure can help others :)