Creating New Project fails finding specified file

Hello forum!

I installed Nsight Tegra - Visual Studio and whenever I want to create a new android project (e.g. native-activity application), it has the following error:

“Android wizard has encountered an error and will terminate: The System could not find file specified”.
The “New Dialogue” opens again. I tried another drive without luck, too.

Nsight Tegra 3.4.16231.3325
Microsoft Visual Studio Community 2015 - Version 14.0.25420.01 Update 3

Using Visual Studio’s project creation for native-activity applications works without any problems.

Thanks for reading, have a great day/evening : )

Hi Lissi,

Could you show me the log at %APPDATA%\NVIDIA Corporation\Nsight Tegra\Logs\Nsight Tegra.log?


Hi victorli!

Here we go:

2017-02-20 19:30:11.9206|INFO|Nvidia.PentaK.Utilities.RedirProcess|1-launch: C:\Program Files (x86)\Android\android-sdk\tools\platform-tools\adb.exe "version" [C:\Program Files (x86)\Android\android-sdk\tools\platform-tools]
2017-02-20 19:30:11.9586|INFO|Nvidia.PentaK.Utilities.RedirProcess|1-stdout:
Android Debug Bridge version 1.0.36
Revision 0e9850346394-android

2017-02-20 19:30:11.9586|INFO|Nvidia.PentaK.Utilities.RedirProcess|1-stderr:

2017-02-20 19:30:11.9586|INFO|Nvidia.PentaK.Utilities.RedirProcess|1-exited: code 0, finished in 31 ms
2017-02-20 19:30:11.9586|INFO|Nvidia.PentaK.Utilities.RedirProcess|2-launch: C:\Program Files (x86)\Android\android-sdk\tools\platform-tools\adb.exe "start-server" [C:\Program Files (x86)\Android\android-sdk\tools\platform-tools]
2017-02-20 19:30:15.9948|INFO|Nvidia.PentaK.Utilities.RedirProcess|2-stderr:

2017-02-20 19:30:15.9948|INFO|Nvidia.PentaK.Utilities.RedirProcess|2-stdout:
* daemon not running. starting it now on port 5037 *
* daemon started successfully *

2017-02-20 19:30:15.9948|INFO|Nvidia.PentaK.Utilities.RedirProcess|2-exited: code 0, finished in 4041 ms
2017-02-20 19:30:16.0118|INFO|Nvidia.PentaK.Target.Android.Tools.AdbClient|[ADB] Received response OKAY
2017-02-20 19:30:16.0118|INFO|Nvidia.PentaK.Target.Android.Tools.AdbClient|[ADB] Connected to adb server
2017-02-20 19:30:16.0118|INFO|Nvidia.PentaK.Target.Android.Tools.AdbClient|[ADB] Received response 0000

Thanks for taking your time to help me out : )

Hi Lissi,

The log you appended seems not to match the issue you met. Please check if you android-sdk is installed and the env variable “ANDROID_HOME” is set.


I fixed it. Sadly there were a ton of other env variables that were stated nowhere : (
Works now : )

Thanks, Victor!