Delete Prop Doesn't Work

I exported my Poker Room scene from IClone, and it came in perfect, except for some of my lights. I went to delete an object, and nothing happens.

I tried deleting hitting delete key on my keyboard, and Edit > Delete.

Is there something I am missing?

Thanks

Hi @DataJuggler! Create does have a couple of known issues related to deleting objects.

  • OM-34129 Content browser refuses to delete exported USD folder and file
  • OM-34855 [CREATE] Unable to delete Collected Assets

Would you be able to share a video of just the content browser? Also, you could attach a copy of our logs to help us troubleshoot the issue? You can grab your logs from here: C:\Users<USERNAME>.nvidia-omniverse\logs\Kit\Create

Thank you for the reply. I am very new to Omniverse. Is the Content Browser the area on the right that lists all the assets in a scene? I see the word content download below, so maybe that is it.

I just tried to record something, and of course delete works due to the observer effect. I think it had to do with exporting from IClone, before I saved it. When I imported from .fbx yesterday may have been when it didn’t work. Today I was able to export from IClone as .usd, and it seems to work.

Thanks again for the reply.

The work around if it happens again is probably just save it as .usd and then reopen it.