Disabling Ertm permanently in Jetpack 4.4 Ubuntu 18.04 on Nano 4GB

Hi All,

I have been able to consistently connect my XBox Bluetooth controller to my Nano 4GB running Jetpack 4.4 using the following CLI command: “echo ‘Y’ > /sys/module/bluetooth/parameters/disable_ertm”.

However every time the Nano reboots Ertm is enabled and I have to resend the “echo ‘Y’ > /sys/module/bluetooth/parameters/disable_ertm” script to disable Ertm so that the XBox controller will reliably connect and stay connected.

I have tried a number of different approaches to automatically disable Ertm at boot up I have tried a number of different approaches, and finally found one that works reliably reboot after reboot:

Step1: Install sysfsutils
sudo apt-get install sysfsutils

Step 2: Edit the config to disable bluetooth ertm
sudo nano /etc/sysfs.conf

Step 3: Append this to the end of the config

Step 4: Reboot your computer
sudo reboot

Step 5: Re-pair the Xbox One Bluetooth Controller

Unpair the controller first, then pair it again.

You should now have a solid light on the xbox button and a stable bluetooth connection.
Regards, TCIII

It’s cool! Thanks for your sharing to community!