Does Jetson Xavier NX module fit in Jetson Nano dev kit?

I see the Jetson Xavier NX is available for purchase now. Does anyone know if I can plug the module into the Jetson Nano dev kit board?

Hi julio.suarez,

Please refer to Considerations when using Jetson Xavier NX module with Nano devkit carrier

Interesting, thanks for the response.

Are there plans to design a new dev board that resolves the power constraint noted in your link?

See this list of Jetson Xavier NX carrier boards offered by Jetson ecosystem partners.

Hi Kayccc,

Jetson Xavier NX module is compatible with Jetson Nano A02 or B01? Because everywhere it is mention compatible with Jetson Nano only. I read somewhere there is some hardware change in A02 and B01 260 pins header.

Hi sindkarhm,

It’s compatible with Jetson Nano B01 - 945-13450-0000- 100 .

I want to use Jetson Xavier NX by using Jetson Nano B01 platform.
But I couldn’t set up them because there is no SD card space in Xavier NX.
How can I use Xavier NX with Jetson Nano B01 board?
Please kindly let me know how to set up.
Thank you.

Of course, I already tried using USB storage device instead of SD card.
So I’m asking you about this problem.

Hi hiro.ohnishi,

Please get the latest SDK manager to flash your NX module + Nano B01 carrier by JetPack 4.4 DP.

Thank you for your reply.
Is it possible to connect the PC(Mac installed Ubuntu) to Jetson NX + Nano B01?
I need USB storage or m2.SSD for getting latest SDK manager?

Hi hiro.ohnishi,

You only can flash the device by connecting with PC, please refer to below install guide to setup your PC: https://docs.nvidia.com/sdk-manager/install-with-sdkm-jetson/index.html

Thank you very much.
I will try it.

By the way, If I want to use the original model created by Tensorflow, should I use TensorRT to run quickly?

Hi,

YES. TensorRT will give you a much better performance on Jetson device.

Please noticed that TensorFlow is not yet available for JetPack4.4.
So you will need to convert the model into a .uff or .onnx file on other platform and create the TensorRT engine from the file on XaiverNX.

Thanks.

I see.

Thank you for your support!

Hi kayccc, It seems the SDK manager doesn’t have sufficient information for how to flash NX/B01 carrier board. I launched SDK manger from a Ubuntu 18.04 host and it is able to recognize NX card as a AGX device but it refused to flash.

Thanks.

Hi kayccc, Please ignore my previous post. I realized I didn’t select the correct device when flashing with SDK manager. Now I chose NX and the SDK manager is able to recognize it, however, it showed the following error and the flash failed.

20:22:30 INFO : Flash Jetson Xavier NX : ./tegraflash.py --chip 0x19 --applet “/home/colin/nvidia/nvidia_sdk/JetPack_4.4_DP_Linux_DP_JETSON_XAVIER_NX/Linux_for_Tegra/bootloader/mb1_t194_prod.bin” --skipuid --soft_fuses tegra194-mb1-soft-fuses-l4t.cfg --bins “mb2_applet nvtboot_applet_t194.bin” --cmd “dump eeprom boardinfo cvm.bin;reboot recovery”
20:22:30 ERROR : Flash Jetson Xavier NX : /usr/bin/env: ‘python’
20:22:30 INFO : Flash Jetson Xavier NX : Reading board information failed.
20:22:30 ERROR : Flash Jetson Xavier NX : : No such file or directory
20:22:30 ERROR : Flash Jetson Xavier NX : [exec_command]: /bin/bash -c /tmp/tmp_NV_L4T_FLASH_XAVIER_NX_WITH_OS_IMAGE_COMP.sh; [error]: exit status 1
20:22:30 INFO : Flash Jetson Xavier NX : [ Component Install Finished with Error ]
20:22:30 INFO : Flash Jetson Xavier NX : [ 224.00 KB used. Disk Avail: 41.08 GB ]
20:22:30 INFO : Flash Jetson Xavier NX : [ NV_L4T_FLASH_XAVIER_NX_WITH_OS_IMAGE_COMP Install took 0s ]
20:22:30 ERROR : Flash Jetson Xavier NX : [error]: Run commands failed at step Install: command /tmp/tmp_NV_L4T_FLASH_XAVIER_NX_WITH_OS_IMAGE_COMP.sh finished with error
20:22:30 INFO : Flash Jetson Xavier NX :
20:22:30 ERROR : Flash Jetson Xavier NX : command terminated with error
20:22:30 ERROR : Flash Jetson Xavier NX : Install ‘Flash Jetson Xavier NX’ failure, command < using adapter to install NV_L4T_FLASH_XAVIER_NX_WITH_OS_IMAGE_COMP@JETSON_XAVIER_NX to /home/colin/nvidia/nvidia_sdk/JetPack_4.4_DP_Linux_DP_JETSON_XAVIER_NX > terminated with error.

I’m using a Ubuntu 18.04 VM that is running inside my laptop, and I use microUSB-to-USB cable to connect NX with my laptop and allow the device passed to Ubuntu VM so that SDK manager in the Ubuntu can access NX. I’m not sure if the above error is because of VM.

Update 1:
I also tried SDK manager on a physical Ubuntu 18.04 host and still got the same flash errors. Hope someone from Nvidia can help. Thanks.

Update 2:
I’m able to flash NX successfully. It doesn’t matter VM or physical Ubuntu. I use Ubuntu 18.04 VM. Here are the steps:
[1] Jumper the board in Force Recovery Mode.
[2] In Ubuntu host, run “ln -s /usr/bin/python3.6 /usr/bin/python”.
[3] Run sdkmanager again, and it may fail at flasing with error unable to connect board.
[4] Do not exit sdkmanager, power cycle NX board (reset might do too), then click retry button in sdkmanager. Flash is able to go through.

I want to use Jetson nano NX by using Jetson Nano B01 platform.

I was able to install SDK manager on the hostPC (ubuntu18.04), but I didn’t know how to migrate SDK manager to Jetson Nano NX.
Error occurs.
[There is not enough disk space to install the selected SDK]

You probably need to remove DeepStream. I’m able to install w/o DeepStream.

I removed DeepStream.
However, I detected the same error.

Is it possible your Ubuntu host doesn’t have sufficient spaces? SDK manager has to download all those packages and save to Ubuntu host before flashing into NX module. Use “df -k” to check if Ubuntu runs out of space.

I checked the capacity of docker container I am using.
There was about 50GB of free space.

スクリーンショット 2020-05-12 10.50.22