Dual GPU on Linux and nvidia-smi no devices were found

I’m using NVIDIA GeForce RTX 3090 which was used for AI Linux Server and also I am using Radeon R9 FURY.

(base) user@user:~$ lspci | grep -i VGA
03:00.0 VGA compatible controller: NVIDIA Corporation GA102 [GeForce RTX 3090] (rev a1)
05:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Fiji [Radeon R9 FURY / NANO Series] (rev c8)

I want to use only NVIDIA GeForce RTX 3090. However, when I only insert 3090, BIOS makes beep sounds (1 long, 3 short) which means it does not detect GPU. However when I use both of GeForce RTX 3090 and Radeon R9 FURY, it won’t happen. And my Ubuntu system lspci command detects both GPUs as I show above.

At this time, I tried to install nvidia driver using ubuntu-drivers install but the system show

UnboundLocalError: local variable 'version' referenced before assignment

As mentioned in here: ubuntu-drivers "UnboundLocalError: local variable 'version' referenced before assignment" when installing nvidia drivers - Ask Ubuntu I fixed the problem. But the main problem is nvidia-smi. Sometime it shows No devices were found or version mismatch. It never worked well.

Here are my brief problem.

  1. When I only use RTX 3090, BIOS sounds GPU error.
  2. When I use both Radeon and RTX 3090, computer is booted and lspci can detect both GPUs. However, nvidia-smi doesn’t even though I install drivers.

I hope to use only RTX 3090, but the first problem blocks me do it.