Dvorak Keyboard

I just need to know how to set my keyboard to Dvorak. Generally I do it through the GUI, which isn’t present. Otherwise, I use setxkbmap, which is again, missing. I see Dvorak as an option out in /usr/share/X11/xkb/symbols/us, and have set the /etc/default/keyboard, and run the dpkg-reconfigure console-setup-linux, but it does not change my keyboard.

Is there any help for me? I can muddle through on a QWERTY keyboard, but I haven’t really used one in 15-20 years. It will slow me up, and I’m afraid that it will introduce errors.

Thank you for any help offered. I appreciate it.


Welcome to the NVIDIA Developer forums. You posted in the networking section of the community. Not sure how your issue relates to NVIDIA products, but it looks like the Linux category best fits your issue. I will move it over for you.

Tom K

Sorry. It is Cumulus Linux that I’m having a problem with. I should have mentioned that. It is used at work, and so I have installed it in a VM here at home and am trying to learn the ins and outs of it, but I’ve been stuck on this all weekend.

I don’t know about cumulus linux but in general, the console keyboard layout should be set by systemd to the one set in /etc/vconsole.conf
Requires reboot/restart of the unit.
Temporarily, you can set the keyboard using
sudo loadkeys

Addendum: the systemd keymaps can be queried/set with localectl
sudo localectl list-keymaps
sudo localectl set-keymap

@jcwoodburn73, Sorry, I will move it to the Cumulus Linux category so the support team has visibility.

Tom K

Can you try to modify the layout with the following command?

sudo dpkg-reconfigure keyboard-configuration

1 Like

I’ve run it a number of times. I picked:

  • Generic 105-key PC (intl.)
  • English (US) - English (Dvorak)
  • The default for the keyboard layout
  • Caps Lock

My /etc/default/keyboard reads:



So, it looks like it is configured, it just isn’t being loaded.

AND … VirtualBox just broke, so I can’t do anything with it until its fixed. Not my day.

Ok. Virtual Box re-installed, dpkg-reconfigure re-run. Looks just like it did, though there is no vconsole.conf file. My keyboard is still QWERTY.

So I had to re-install VirtualBox, and I re-imported the Cumulus Linux .ova file.

There is no /etc/vconsole.conf file. When I tried the localectl list-keymaps, “Failed to read list of keymaps: No such file or directory”.

Please install the keymaps
sudo apt install console-keymaps

No go.

E: Unable to locate package console-keymaps


I’ve tried to setup a virtual box with Cumulus VX running 4.3.0 and I have not been able to change the layout. As you mentioned, some of the deb files required form other forums suggesting how to enable dvorak are not available in cumulus linux.

I used a windows VirtualBox app. I I change the layout on the vbox host (windows) to dvorak, this is passed to the console window. I wonder how you are using vbox in your environment and if this is an option

Another alternative is once you have your Cumulus Box you could SSH into the device rather than using the console. SSH should inherit the keystrokes passed transparently from your client to the switch.

If that is still not the case, you can still push ansible playbook which you create in any environment that has support for your dvorak keymap .