[Error] [carb] Plugin: omni.livestream-websocket.plugin.dll. Error: The specified module could not be found

I am using Omniverse Create v2021.3.8 on AWS Windows Virtual Machine. I’m getting the error while enabling the WebSocket extension.

Please find the attached log file for the same.

Error -
2022-04-21 06:48:37 [Error] [carb] [Plugin: omni.livestream-websocket.plugin.dll] Could not load the dynamic library from c:/users/administrator/desktop/nucleus poughkeepsie/kit/create.next/2021.3/exts/3/omni.kit.livestream.websocket-2.0.14+102.0.wx64.r.cp37/plugins/omni.livestream-websocket.plugin.dll. Error: The specified module could not be found.
2022-04-21 06:48:37 [Warning] [carb] Potential plugin preload failed: c:/users/administrator/desktop/nucleus poughkeepsie/kit/create.next/2021.3/exts/3/omni.kit.livestream.websocket-2.0.14+102.0.wx64.r.cp37/plugins/omni.livestream-websocket.plugin.dll
2022-04-21 06:48:37 [Error] [omni.ext.plugin] [ext: omni.kit.livestream.websocket-2.0.14] failed to load native plugin: c:/users/administrator/desktop/nucleus poughkeepsie/kit/create.next/2021.3/exts/3/omni.kit.livestream.websocket-2.0.14+102.0.wx64.r.cp37/plugins/omni.livestream-websocket.plugin.dll
2022-04-21 06:48:37 [Error] [carb] [Plugin: omni.kit.livestream.plugin] Dependency: [carb::livestream::Vision v0.3] failed to be resolved.
2022-04-21 06:48:37 [Error] [carb] [Plugin: omni.kit.livestream.plugin] Dependency: [carb::livestream::Vision v0.3] failed to be resolved.
2022-04-21 06:48:37 [Error] [carb.scripting-python.plugin] RuntimeError: Failed to acquire interface: omni::kit::livestream::ILivestream (pluginName: nullptr)

At:
c:\users\administrator\desktop\nucleus poughkeepsie\kit\create.next\2021.3\exts\3\omni.kit.livestream.websocket-2.0.14+102.0.wx64.r.cp37\omni\kit\livestream\websocket\extension.py(307): on_startup
c:/users/administrator/appdata/local/ov/pkg/create-2021.3.8/kit/plugins/bindings-python\omni\ext\impl_internal.py(141): _startup_ext
c:/users/administrator/appdata/local/ov/pkg/create-2021.3.8/kit/plugins/bindings-python\omni\ext\impl_internal.py(174): startup_all_extensions_in_module
c:/users/administrator/appdata/local/ov/pkg/create-2021.3.8/kit/plugins/bindings-python\omni\ext\impl_internal.py(225): startup_all_extensions_in_module
PythonExtension.cpp::startup()(2):
c:\users\administrator\appdata\local\ov\pkg\create-2021.3.8\kit\exts\omni.kit.window.extensions\omni\kit\window\extensions\ext_commands.py(30): do
c:\users\administrator\appdata\local\ov\pkg\create-2021.3.8\kit\extscore\omni.kit.commands\omni\kit\undo\undo.py(74): execute
c:\users\administrator\appdata\local\ov\pkg\create-2021.3.8\kit\extscore\omni.kit.commands\omni\kit\commands\command.py(235): execute
c:\users\administrator\appdata\local\ov\pkg\create-2021.3.8\kit\exts\omni.kit.window.extensions\omni\kit\window\extensions\utils.py(47): toggle_extension
c:\users\administrator\appdata\local\ov\pkg\create-2021.3.8\kit\exts\omni.kit.window.extensions\omni\kit\window\extensions\ext_components.py(79): toggle
c:\users\administrator\appdata\local\ov\pkg\create-2021.3.8\kit\exts\omni.kit.window.extensions\omni\kit\window\extensions\ext_components.py(89):
2022-04-21 06:48:37 [Error] [omni.ext.plugin] [ext: omni.kit.livestream.websocket-2.0.14] Failed to process python module extension in ‘c:/users/administrator/desktop/nucleus poughkeepsie/kit/create.next/2021.3/exts/3/omni.kit.livestream.websocket-2.0.14+102.0.wx64.r.cp37/.’.
2022-04-21 06:48:37 [Error] [carb.scripting-python.plugin] AssertionError: jinja2 must be installed to use Jinja2Templates

At:
c:\users\administrator\appdata\local\ov\pkg\create-2021.3.8\kit\extscore\omni.kit.pip_archive\pip_prebundle\starlette\templating.py(52): init
c:\users\administrator\appdata\local\ov\pkg\create-2021.3.8\extscache\omni.services.streamclient.websocket-1.1.7+cp37\omni\services\streamclient\websocket\extension.py(23): on_startup
c:/users/administrator/appdata/local/ov/pkg/create-2021.3.8/kit/plugins/bindings-python\omni\ext\impl_internal.py(141): _startup_ext
c:/users/administrator/appdata/local/ov/pkg/create-2021.3.8/kit/plugins/bindings-python\omni\ext\impl_internal.py(174): startup_all_extensions_in_module
c:/users/administrator/appdata/local/ov/pkg/create-2021.3.8/kit/plugins/bindings-python\omni\ext\impl_internal.py(225): startup_all_extensions_in_module
PythonExtension.cpp::startup()(2):
c:\users\administrator\appdata\local\ov\pkg\create-2021.3.8\kit\exts\omni.kit.window.extensions\omni\kit\window\extensions\ext_commands.py(30): do
c:\users\administrator\appdata\local\ov\pkg\create-2021.3.8\kit\extscore\omni.kit.commands\omni\kit\undo\undo.py(74): execute
c:\users\administrator\appdata\local\ov\pkg\create-2021.3.8\kit\extscore\omni.kit.commands\omni\kit\commands\command.py(235): execute
c:\users\administrator\appdata\local\ov\pkg\create-2021.3.8\kit\exts\omni.kit.window.extensions\omni\kit\window\extensions\utils.py(47): toggle_extension
c:\users\administrator\appdata\local\ov\pkg\create-2021.3.8\kit\exts\omni.kit.window.extensions\omni\kit\window\extensions\ext_components.py(79): toggle
c:\users\administrator\appdata\local\ov\pkg\create-2021.3.8\kit\exts\omni.kit.window.extensions\omni\kit\window\extensions\ext_components.py(89):
2022-04-21 06:48:37 [Error] [omni.ext.plugin] [ext: omni.services.streamclient.websocket-1.1.7] Failed to process python module extension in ‘c:/users/administrator/appdata/local/ov/pkg/create-2021.3.8/extscache/omni.services.streamclient.websocket-1.1.7+cp37/.’.
kit_20220421_064804.log (604.1 KB)

1 Like

Hello @mdevdha1! I contacted the dev team for more help in figuring on this error as well. I will let you know when I have more information for you!

I am getting the same issue