ERROR: JETSON TX2 Flashing jetpack 4.6.3, flash failed

Tx2 failure log.odt (24.1 KB)

I am trying to flash jetson 4.6.3 jetpack on Tx2 board, the flashing process is getting failed.

Log file is attached please check.

If you don’t use all these parameters but just pure full flash, will it pass?

sudo ./ -r -d kernel/dtb/tegra186-quill-p3310-1000-c03-00-base.dtb -K kernel/Image jetson-tx2-devkit mmcblk0p1

Thanks for quick response,
First I was flashed through SDK manager application.At that time nviadia directory created at home directory in host system.
After that I followed one link that i will share you below.

In that i download the toolchain,kernel source files.Build that files and generated the Image and copy that generated image and dtb files to JETPACK. After that tried to flash using but i am getting the flash failed issue observed in below attached image .

How to overcome the issue.



  1. The board can be flashed with sdkmanager without issue

  2. The issue only happened after you customized something.

If above are correct, please put your kernel image to Linux_for_Tegra/kernel/Image
and your dtb to Linux_for_Tegra/kernel/dtb

and run full flash command. Do not add anyhting like -r -d -K things in your flash command. Tell me if you can flash it.

Thankyou @WayneWWW ,

I copied image and dtb image files as you said and run sudo ./ /home/argus/nvidia/nvidia_sdk/JetPack_4.6.3_Linux_JETSON_TX2_TARGETS/Linux_for_Tegra/kernel/Image jetson-tx2-devkit mmcblk0p1 command but same error.
Error: Return value 1 what does it mean.
Clarifying point no 2. trying to flash kernal source code as it is. I am using the file from the link

Hi @sateeshargus

I am not sure if you notice it or not. The version you are using is jetpack4.6.3. This is latest rel-32.7.3 BSP.

But the source code you are using is rel-32.1 source code… it is 3 years older than the BSP you are using… mismatch source code will not work…

I downloaded latest rel-32.7.3 BSP [Driver Package (BSP) Sources] from this link.
Build the kernel and generated the image. Copy that image in to /kernel/Image and dtb files in to /kernel/dtb directories and done full flash getting same error.

Please find the attached log file.
bsp_changed_log.txt (52.5 KB)


I don’t know why you still add something weird in your command.

sudo ./ /home/argus/nvidia/nvidia_sdk/JetPack_4.6.3_Linux_JETSON_TX2_TARGETS/Linux_for_Tegra/kernel/Image jetson-tx2 mmcblk0p1

When I said full flash, it is just

sudo ./ jetson-tx2 mmcblk0p1

Is it okay to run this? Did you get the point that you already updated the file so you don’t need to put anything else in the as input?

Also, if even this one fails

sudo ./ jetson-tx2 mmcblk0p1

Could you tell me if you don’t modify anything (default image/dtb), will it be able to flash your board?

If even the clean setup cannot flash, then we need to check something else.

Yes, I did not modified anything but I build the kernel and tried to flash it.
Default files also i am unable to flash.

i had run the below command.
sudo ./ jetson-tx2 mmcblk0p1
I have done what you said in above post but i am facing same issue.
is there any other way to solve.


No, I mean if you did not ever change anything. Do not replace kernel. Do not replace dtb.

Just use default BSP or directly using sdkmanager to flash. Will it pass or not?

Even your “rebuild kernel” is a customization to me. I don’t want that appeared for now.

Also, could you take a picture of your board?

Also, if you have any question about what I said, please ask it before you try anything.

For example, if you don’t know what is sdkmanager, please also tell too.

Using sdkmanager the flashing is completed successfully.
Please find the attached document for sdkmanager through flash images.
images.odt (2.3 MB)

After flashing the sdkmanager I supposed to build the kernel source code from BSP. And tried to flash it.I did not changed anything on the BSP files.
Is this the correct way what i was done.


The issue here is not related to the kernel image. The problem here is you used the wrong board config from the beginning. sdkmanager says your board is tx2i. Not tx2.

So the board config is not jetson-tx2. That is why manual flash cannot work but sdkmanager can.

BTW, next time you want to share sdkmanager log ,there is a “EXPORT LOGS” button on your sdkm GUI. Please use that to dump text log.

I will change board config to jetson-tx2i and try that and update.

Thanks alot @WayneWWW

Its working, by replacing board config with jetson-tx2i.

Board: Jetson Tx2i
Jetpack version: 4.6.3
BSP release: L4T 32.7.3

Jetpack with Supported BSP release version should be considered.

I don’t know what is needed to be considered here…

Jetpack with Supported BSP release version should be considered.

Every thing you are using here is already in jetpack. What are you trying to say here?

For my understanding.

Thanks for your support.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.