Error: Probing the target board failed

I’m trying to flash my TX2 for the first time, with varying degrees of failure.

The tx2-specific shell script in my Linux_for_Tegra folder fails in the gui. I tried running it directly (which pointed out a missing ‘python’). In the diagnosis efforts here on this forum, someone suggested running directly from the console thusly:

sudo ./ jetson-tx2 mmcblk0p1

but that just results in:


L4T BSP Information:

R32 , REVISION: 4.2

Error: probing the target board failed.
Make sure the target board is connected through
USB port and is in recovery mode.

This despite this output from lsusb:

Bus 002 Device 013: ID 0955:7c18 NVidia Corp.

I’ve already installed python2 to the Ubuntu 18.04 image I downloaded from this site, which is more than a little frustrating. You’d think they could make this process less painful with a little effort on their end.

I also sudo apt remove tlp as recommended in a similar “probing the target board failed” message, still no go.

I’m using a real installation on the host, not a virtual machine.


Is the host a VM? Are you using the micro-B USB cable which comes with the dev kit?

Typically VMs lose the connection, and cheap charger cables tend to fail part way into a flash.

Real install, not a virtual machine.

I am using the micro-usb that came with the board.

In this case it should be working, especially since lsusb worked correctly.

You might want to set everything up for flash, verify lsusb again, and then monitor “dmesg --follow”. When the error occurs, does the dmesg log add anything new, especially USB errors?

As an experiment, when you get this error, see what happens if you unplug and then replug the micro-USB cable from the host. USB is hot plug, and possibly a simple unplug/replug will cause the flash software to recognize the device again (typically only a VM would care about this, but it has me curious if a regular host port is losing the connection).

1 Like

dmesg --follow didn’t show anything new when I failed to flash.

HOWEVER, when I unplugged and replugged the micro-usb, I was able to flash my board and it booted up just fine.

Thank you for your help!

I don’t know why it occurs, but sometimes hot plug works when cold plug does not. Something on the host side apparently “does the right thing” when already booted and USB is replugged, but sometimes not when USB is connected from the start of boot or prior to flash. “Hot plug is your friend”. :P

1 Like