Error when flashing: /dev/ttyUSB3 not found on host

Hardware Platform: DRIVE AGX Xavier™ Developer Kit
Software Version: DRIVE Software 10.0
Host Machine Version: native Ubuntu 18.04
SDK Manager Version:

When trying to flash my machine with the SDK Manager, I receive the following error:
/dev/ttyUSB3 not found on host. Please make sure no /dev/ttyUSB* files exist on host first then connect target board to host. Once connected, /dev/ttyUSB3 can be found.

I checked the Flashing Technical Bulletin ( and found a possibly related issue under point 2.2. I checked my linux kernel version but it is 5.3.0-40 and not one of the described versions. I still tried the suggested workaround but my error persists with linux kernel version 4.15.0-88, which is listed as a version that provides resolution.

Hi @philipp.heidenreichdo0x6,

I saw your created TensorRT installation on Drive AGX. Is this still a problem on your side? Thanks!

this problem still persists. We used to be able to flash our Drive AGX and install Drive Software 10.0. But I was trying to flash it again to make sure TensorRT is correctly installed. However, when trying to flash it, I received the error described in this thread. I recently updated the SDK Manager to version, so the error might have been introduced in one of the updates.

Please make sure use USB 2.0 cable to connect to “Debug” port. Please check Setting Up the E3550 Platform for the details. Thanks!

thanks, I was connected via Ethernet instead of USB. I suggest the error messages in the SDK Manager could be improved to facilitate fixing these kinds of issues.
Still, I am not able to flash my device due to another error (sdkm.log (335.7 KB)).

Since the error seems to start due to libsm-dev (see log around 15:20:56.278), i checked:

apt list libsm-dev
Listing… Done
libsm-dev/bionic,now 2:1.2.2-1 amd64 [installed]

Is your DRIVE AGX system “E3550”?

Please try if removing sdk directory with below command helps. Thanks!
$ rm -rf ~/nvidia/nvidia_sdk/DRIVE_Software_10.0_Linux_OS*

Also have you ever successfully installed?

Yes my Drive AGX system is E3550. We were able to install back in March. I was trying to reinstall it because of problems with the TensorRT library as discussed in TensorRT installation on Drive AGX.

I tried your proposed approach and now run into another kind of error (sdkm.log (266.4 KB)).

I saw the error message from your log. Please check if you have the directory created.

11:23:25.444 - info: NV_DRIVE_PLATFORM_RFS_TARGET_COMP@DDPX: ERROR: source directory /home/opelai/nvidia/nvidia_sdk/DRIVE_Software_10.0_Linux_OS_DDPX/DriveSW_Components/TargetDebs not found

Is this from reinstalling after rm nvidia_sdk directories?
$ rm -rf ~/nvidia/nvidia_sdk/DRIVE_Software_10.0_Linux_OS*