Failed to install Code 2023.1.1

I have tried using the cleaner tool, reboot my machine, and reinstall the launcher, but the problem persists.

Launcher log is presented below:

launcher.log (99.0 KB)

I can install Isaac Sim and other apps without issue as you can see in the log.

I am running Windows 11 22631.3593

It looks like you tried first and your “auth token” was refused, meaning you may have tried to install Code whilst not having a fresh Launcher login. So it failed. Then you went back and logged in but tried to install again and again, but it says it is “alreedy in progress”.

Try just completely restarting the machine, logging into Launcher fresh. Make sure you clear out any old “Code” install packages from your “deps” folder and then try again.

Speaking of this “already in progress” thing, I cannot get rid of that message even after a reboot. And two “Waiting for authentication… + Initializing code@2023.1.1 installer… + Fetching code information…” with a time gap less than one second are recorded in the log just before the “already in progress” error. I believe that this is irreverent (still might be a bug though).

I did a logout + login, cleared the whole deps directory and the cache directory, but the problem persists.

launcher.log (142.7 KB)

Ok it seems that there are some connection issue between Chinese mainland and cloudfront. I’m trying to use proxy to see if that works.

That works after I tried copying the thing inside deps before it gets deleted and run the pull_kit_sdk.bat for multiple times (3 as I remember, maybe amazon does not like datacenter IPs that much. Maybe add more retries when pulling extensions?). After the pull_kit_sdk.bat exits without complaining anything, I do the installation inside the launcher and now code gets installed.

But now some junks are left on my drives since the installation process is not fully controlled by the launcher. Are packman-repo and all the stuffs inside deps safe to delete?

I would think it is ok to delete yes. But if not undelete it.
So it sounds like your internet provider was having trouble pulling down the required live files. Glad you got it to work.