Flashing Orin NX 16GB - SSH is not ready

I am trying to flash my Orin NX 16GB module with JetPack 5.1.1, on a native Ubuntu20 host. I am not using the dev kit, but I am also facing this issue with two different carrier boards and I have not had success troubleshooting this with the board manufacturers, so I am wondering if it could be an issue with my NX module.

Here are my steps for flashing:

  1. I put the board in recovery, lsusb shows 0955:7323 NVIDIA Corp. APX
  2. I run the flash command with sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" --showlogs --network usb0 jetson-orin-nano-devkit internal. This includes the vendors’ BSP files.

The script times out with:
Waiting for target to boot-up…
Waiting for device to expose ssh …RTNETLINK answers: File exists
RTNETLINK answers: File exists
Waiting for device to expose ssh …Run command: flash on fc00:1:1:0::2
SSH is not ready
Cleaning up…

At this point, lsusb shows 0955:7035 NVIDIA Corp. Linux for Tegra

I have tried increasing the timeout count in l4t_network_flash.func but it still eventually times out in the same way. I have attached the host logs.
logs_ssh_error.txt (241.8 KB)

I’d appreciate any advice to troubleshoot this. Thank you.


Please also dump the serial console log during flashing.
Flashing log is not enough for debugging here.

Or just try again with an NVIDIA DevKit.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.