Frame Generation tanking FPS

Hi, I’m having trouble with the NVIDIA DLSS Frame Generation plugin in Unreal Engine 5.3.

I’m working on a project where we’d like to use both DLSS and frame generation, and while DLSS seems to be working great the frame generation plugin has some issues I’m not able to 100% figure out. When enabled, framerate slowly tanks until the game thread is at about 90ms. Unreal Insights doesn’t really give much information as to why, and looking at the debug tools for streamline there’s some concerning values there: under sl.reflex, the “FPS cap” value skyrockets, as does the “Sleeping” ms.

Thank you!

Hi @cooleaddento and welcome to the NVIDIA developer forums.

Difficult to say from just that screenshot what might be going wrong.

First of all please share

  • Hardware specs like CPU, GPU, RAM
  • Software specs like OS, GPU driver version, Unreal version, Plugin version

Did you go through the Troubleshoot section in the DLSS_Frame_Generation_Quick_Start_Guide.pdf?

For our engineers to give any advice they will need at least the log output mentioned there which relates to Streamline, Reflex and DLSS. Also stats threadingwould be helpful to see what Reflex does to the Game Thread.

Hey Markus,

Thank you for pointing me in the right direction! I had looked through the quick start guide a few times but I had missed this here:

Due to how UnrealEngine handles framerate limiting, there may be issues where the framerate gets stuck at the minimum framerate and doesn’t recover. The console variable t.Streamline.Reflex.HandleMaxTickRate can be set to False to let the engine limit the max tick rate instead of Streamline Reflex, which may help these situations. The engine is unaware of DLSS frame generation, so the actual graphics framerate may be effectively double what the engine’s max FPS is set to when this cvar is False.

This seems to have solved my issue, though I’m not 100% sure if this will cause any problems with Frame Generation. Let me know if there’s any potential issues with enabling this at all times.

I think this would also be good as an enable / disable check box in the plugin settings. The quick start guide seems to imply it’s a known issue, so a solution that’s not deep in documentation could be helpful for others who experience this problem out of the box.

Thank you!