FrameController: Timeout waiting for workload results

Hello,

I’m trying to do graphics debugging locally with Nsight 3.2.2.13351. The application I’m debugging is 64-bit and uses Direct3D 11. The OS is Windows 7 x64 and I’m building the application with Visual Studio 2010. My GPU is Nvidia GTX 570 and the driver version is 332.21.

So first I click ‘Start Graphics Debugging’ in Visual Studio and the application launches as it should. Everything works fine until I click pause and capture frame. After that in Graphics Inspector when I click ‘Profile Frame 1’ or ‘Frame Timings’ I get the following error messages: ‘An error occurred while running the experiment’ and ‘FrameController: Timeout waiting for workload results’.

This used to work before, and I have no idea what has happened since then. I also tried installing a 3.1 version of Nsight, but that doesn’t work anymore either. Any ideas what could cause these error messages?

Hi,

I am finding out more details about why this error could come up. In the mean time, is there a way for me to get a reproducible/a set of binaries that I can run to reproduce the problem?
If so, please PM me.

Thank you

Unfortunately it’s not possible for me to send the binaries.

Hi,

The good news is that this is not reproducible with the latest (internal) drivers & Nsight, however, there are some cases that are still being worked out.

Thanks

Is there any more information about this issue? I’ve tried different driver and Nsight versions but nothing works. I also checked ‘Nsight.log’ file. This error seems to be related to the problem:

Error,02/13/2014 14:03:22,devenv.exe,’’ id: 1,FrameDebugger,"Graphics Target Interception: Error
",MessageChannel1.NotifySubscribers => DeviceMessageQueue.ChannelMessageHandler => DeviceMessageQueue.NotifySubscribers => SubscriptionFilter1.Nvda.Device.ISubscriptionFilter.Match => FrameDebugger.OnGraphicsFailure => NLogLogger.Log => NLogLogger.LogCore