Getting Aurix Easy CAN to work

Hardware Platform: DriveWorks AGX Xavier
Software Version: Drive Software 2.2
Host Machine Version: Ubuntu 18.04.4 LTS (Bionic Beaver)
SDK Manager Version:


I am trying get EasyCAN to work on Aurix CAN port on SOC#F (CAN6&4, pin7&2).

So far, I’ve done following:

  1. In Easy CAN Usage section in Development Guide here:

  2. Updated Baudrate from aurix using “cansetbr f 250”

  3. Added message to EasyCANConfigFile as follows:
    MsgId : 0x05C
    CtrlId: EC_CAN_BUS_F

  4. I also added configure_rx_message(0x05C,3,0,1) in and ran that python script.

  5. In the Drive_AGX_EB_AURIX_Software_UserGuide.pdf in Appendix Section i read that running would send and receive messages from Aurix and will print them in terminal. I do not see any message printing.

  6. Then I ran ./sample_canbus_logger --driver=can.aurix --params=ip=,bus=f,config-file= **/my/path/to/EasyCanConfigFile.conf**.

After a few tries I could see 0x05C messages were received. I stopped it to understand what did i do that made it work and it never worked after that.

Do I just need to run either the or provide the path to EasyCanConfigFile.conf.? Because when running either one, Aurix Terminal tells me same thing “Received Configuration” and “Configuration Updated”.

EasyCANUsage doesn’t have configuration information, it talks about how does it work and how to test it. I found some information on the Drive_AGX_EB_AURIX_Software_UserGuide.pdf but information there is scattered. I guess I will tryin to go through it a few times over the weekend.

I need your help figuring out how to get this to work. Let me know if you need more information.

Thanks in advance.


Dear @rborad,
Could you check EasyCan Usage on Drive Software 10.0 for your topic to see if it helps. Please confirm if everything is working fine before adding your new message?

@SivaRamaKrishnaNV, thank you for your reply. i was able to get this to work. I don’t know what the problem was, maybe restart needed but most of all i needed a break from trying to get it working. Also, i did follow this link. it is really helpful.

Now that i have it working, how do i run ./sampl_imu_logger using can.aurix as a device?

When I used SocketCAN i ran below command:
./sample_imu_logger --driver=imu.custom --params=decoder-path=/path/to/my/,can.socket,device=slcan0

Below command to run CAN data logger
./sample_canbus_logger --driver=can.aurix --params=ip=, bus=f,config-file=/path/to/my/config.conf

I tried mixing this but i got errors. Thanks in advance.


Dear @rborad,
I don’t see can.aurix in list of driver parameters for IMU logger sample.

1 Like