GTX 770M Linux compatibility

Hi guys,

I was wondering if someone has experience on using the new GTX 770M on notebooks like the new Asus G750JX and it’s compatibilities with various linux distribution naming ubuntu, arch, mint, etc.7
Are there any problems I’ve to expect?

Thanks in advance!


I bought an Asus G750JX and I can tell you that you’re going to have problems installing Ubuntu. The CD hangs at a black screen after getting through the GRUB menu, merely displaying that the “binary is whitelisted” if secure boot is enabled on the UEFI. However, Ubuntu is allowed to install fine when running on Compatibility mode which emulates a BIOS environment. I don’t know if the GTX 770M has anything to do with the compatibility issues, however. Also, I saw somewhere else that installing another OS besides Windows 8 will void your warranty, so I’d be careful for that.

I don’t know how other flavors of Linux will work with UEFI enabled, but I do know you at least need 12.04.2 Ubuntu or 12.10 64-bit Quantal Quetzal in order for Linux to be registered with Secure Boot.

Optimus will be your greatest concern I guess.

If I were to choose a laptop specifically for Linux, I’d choose a model without any discrete graphics card - it’s gonna be cheaper, will definitely work more from the battery and you won’t have to deal with proprietary drivers and bumblebee.

Optimus is just a PITA in Linux and it will always be, unless nouveau catches up with NVIDIA - but that’s not gonna happen in the next ten years, but then NVIDIA will become irrelevant and disappear from the desktop GPUs market - Intel will simply force them out by integrating more and more powerful GPUs and by being the first to introduce new nodes. At 7nm or less Intel will be unreachable for other semiconductor factories for quite some time and they will surely take advantage of it.

There’s 0.1% chance that NVIDIA will open source their drivers and that’s gonna be something the world has never seen before.

And there’s a 1% chance that NVIDIA, just like AMD with its open source drivers, will start helping Nouveau by releasing some specifications. I still cannot understand why NVIDIA cannot release their specs under NDA so that Nouveau developers could actually write code instead of doing a ton of guesswork by reengineering the blob.

Sometimes I don’t quite understand Jen-Hsun Huang - it’s all in his power and NVIDIA doesn’t really lose anything by being more friendly towards Linux - instead they get recognition and praise amongst IT people.

When I received my G750JX, I powered on and saw windows working correctly. This step was necessary to control that the hardware is ok.
Next, I tried installing Ubuntu 13.04 with UEFI: no success. I saw these problems:

The USB port on the left are not accessible at boot time correctly: the installation starts, but during the process, the usb key becomes not readable. the usb on the right seems better but not enough. I finally burned a CD with another PC and loaded UBUNTU.

When restarted: black screen !

The process had a duration of 3 days. To be short, forget UEFI , disable fastboot that creates real problems when you reboot, you keep the wrong values !
In the BIOS remove UEFI and use legacy disk system. That way it loads perfectly.

Next, update ubuntu and install NVidia driver from there website I use the BETA version and work except that I cannot change the screen brightness.

this device is a real pleasure !

I was able to load the latest 12.04.3 version of Ubuntu Stable (64-bit) on the asus laptop with uefi and secure boot enabled. But then I couldn’t launch Windows from GRUB because of secure boot problems and then improperly mapped hard drive device after I turned off secure boot. Had to boot Windows from the ESC boot menu.

Also, when I did have Ubuntu loaded, the power management tab in system options didn’t have options for what to do when you close the lid or when you’re on battery power. I also tried to look manually with gconf-editor and it wasn’t there either, so I’m wondering if it’s an OS thing or if the laptop doesn’t signal Ubuntu that it is indeed a laptop.

I’ve got a 770M in my Toshiba Qosmio. I have not been able to get the latest NV driver working, 331.20, with OpenSuse 13.1, Linux kernel 3.11.6 . The Nouveau driver works very well, however.

With the GEForce driver, I had to configure the PCI BusID in the configuration to get it to see the card, but even blacklisting the i915 intel driver never got a working X.

BTW: I did buy this laptop intending to use the CUDA cores for numerical calculations, so I’m eager to get the driver working.