Had working Omniverse Isaac Sim + Isaac SDK, now Isaac Sim launcher stays blank

Need help. We had an almost fully functioning Omniverse Isaac Sim. After some driver, card, and kernel upgrades and downgrades it is no longer launching, even after multiple Isaac Sim version uninstall and reinstall.

Stays stuck at this screen:

Screenshot from 2022-04-01 09-50-31

So the next step we were thinking of is to reinstall Omniverse completely, but worried about whether you will allow re-downloading a version of Isaac Sim with Robot Engine Bridge which is needed for Isaac SDK integration, together with matching assets.

If it is not obvious whether Isaac 2021.2.1 can be downloaded together with matching assets and robot engine bridge, I can provide all details of the current installation so that it can be made working again.

Hi. Please share your Isaac Sim and Isaac Sim App Selector logs and the output of nvidia-smi.
Are you able to run Create and Code?

Thank you so much. I didn’t know there are logs for Isaac Sim and Isaac Sim App Selector. Since you asked about those logs, I was able to find them and looking for the first big error I saw that LibGLU.so could not be found. Then I installed it based on the following link:

Now Isaac Sim 2021.2.1 launches again, and Isaac SDK and Robot Engine Bridge seem to be working as well, at least for the sortbot_sim example.

The cart_delivery example almost works, but it appears to think the bounding box is in front of the cart. So the STR approaches the cart, thinks it is underneath it when it is still in front, then lifts and starts moving to the destination while the cart is still at its original location never loaded onto the STR.

I assume this was working in Isaac Sim + Isaac SDK when it was released but I don’t know why it isn’t working on my system. I have not modified any of this code. I was just struggling with graphics drivers and video cards to finally find a combination that allows Isaac Sim + Isaac SDK to work together.

Here is the output of nvidia-smi

| NVIDIA-SMI 470.161.03   Driver Version: 470.161.03   CUDA Version: 11.4     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0  On |                  N/A |
| 36%   63C    P2   138W / 190W |   3681MiB /  5926MiB |    100%      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A      1794      G   /usr/lib/xorg/Xorg                156MiB |
|    0   N/A  N/A      2104      G   /usr/bin/gnome-shell               38MiB |
|    0   N/A  N/A      3169      G   ...RendererForSitePerProcess        9MiB |
|    0   N/A  N/A      4054      G   /usr/lib/firefox/firefox          156MiB |
|    0   N/A  N/A     13881    C+G   ...saac_sim-2021.2.1/kit/kit     2465MiB |
|    0   N/A  N/A     16768      G   /usr/bin/nvidia-settings            0MiB |
|    0   N/A  N/A     21460      C   /usr/bin/python3                  843MiB |

Since the launching issue is solved, I can make a separate thread about the Isaac Sim Cart Delivery example almost working but not quite successful.

For future reference, is it possible to re-download Isaac Sim 2021.2.1 with robot engine bridge and matching assets if it is ever needed ?

Looks good.

I’m afraid we no longer support Isaac Sim 2021.2.1 but the assets are still available.
To access the assets add the Isaac mount with the S3 url: https://d28dzv1nop4bat.cloudfront.net

See this topic for more details:

Wonderful. Please please please do not delete Isaac Sim 2021.2.1 or the assets, at least until you have the same assets with robot engine bridge working in newer versions of Isaac Sim.

Thanks again for your prompt replies, we appreciate the support

PS: Here’s a screenshot


Sure. We will try to keep that assets URL alive for as long as we can. :)

I’m curious, which assets specifically are you using with REB? Just that carton and trolley? Have you tried our latest version with Isaac ROS? I believe the assets should still be in the new version.

We use sortbot_sim, carter_warehouse, ur10, franka_table, jetbot_follow_me, essentially all the SDK assets in Isaac Sim.

In fact we really love your Isaac SDK, it is a wonderful and reasonably complete ecosystem for developing physical robots. We have working Jetbot, Kaya, Carter, UR robots and are exploring all the amazing GEMs and algorithms that Isaac SDK has to offer. Isaac Sim is useful to us, but not as a standalone tool, but rather as a tool supporting Isaac SDK.

So that’s why we’re surprised that Robot Engine Bridge was nowhere to be found on newer Isaac Sim and we had to reactivate the last version that supported it. And hoping that if this computer dies for any reason, that we can re-download Omniverse with Isaac Sim 2021.2.1 itself too, and not just the assets. Or hoping you will re-enable Robot Engine Bridge for newer Isaac Sim, as long as the Isaac SDK assets can also still be loaded into the newer Isaac Sim.

Regarding ROS, it would feel like starting over, after we already have a working Isaac SDK system with Carter, Kaya, Jetbot robots and their digital twins and enabling the full sim-to-real experience promised by Nvidia.

Right. That makes sense. ROS will be a huge change. Thank you for your support :)
That old version should still work but I am not sure of the future of REB and Isaac SDK.

I think we should be able to recreate or convert any old assets to the new Isaac Sim.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.