How can I disable the graphical and the terminal?

How can I disable the graphical and the terminal? I connect the screen. I don’t want the screen to display the terminal or graplhical. How the set it?

systemctl set-default
It will display the terminal on the screen.

So what do you want over the terminal? Just a blanked screen?

The framebuffer console (what you called "terminal), shall be enabled by default.

Yes!Just a blanked screen. Can the system set it?

Go to the kernel config file and disable the framebuffer console, rebuild the kernel and put it on the board.

My APP is drm mode. Will the setting effect the app display?
And will the debug serial port work well?
And can you show me which selection I should select?

kernel/kernel-4.9/arch/arm64/configs/tegra_defconfig → remove CONFIG_FRAMEBUFFER_CONSOLE=y

1 Like

I found that if I remove CONFIG_FRAMEBUFFER_CONSOLE=y. My app will be error

nvbuf_utils: Could not get EGL display connection
nvbuf_utils: ERROR getting proc addr of eglCreateImageKHR
nvbuf_utils: ERROR getting proc addr of eglDestroyImageKHR

The 08 sample will be too.
The Image compile I do

make ARCH=arm64 tegra_defconfig
make menuconfig ARCH=arm64 CROSS_COMPILE=aarch64-linux-gnu- LOCALVERSION=-tegra

I “make menuconfig” to remove the CONFIG_FRAMEBUFFER_CONSOLE.
My app works on drm.

EGL display requires X to run. Not framebuffer console…

This error is no surprise to me after you disable the graphic.

That means I can’t disable the CONFIG_FRAMEBUFFER_CONSOLE?

No, I didn’t mean that…

Any problem in understanding below comment?

This error is no surprise to me after you disable the graphic.

But I don’t disable the graphic

Is “xrandr” still giving out result?

sudo xrandr
Can’t open display

But I just use the drm. I don’t use x.

Can you try to elaborate more detail? I really cannot understand what you are trying to say.

For example, why do you still have EGL but you also said you are using DRM? Is there any argus camera in use? Argus camera also needs X to help for running.

Please do not run sudo for xrandr. Also, when xrandr says no display, make sure you have X server running and local var DISPLAY=:0 is set.

I use drm.,Decoder, cuda,opengl.
I run the app after

sudo systemctl set-default

I see the sample 08 has the same error

./video_dec_drm --disable-video

My app has 2 layouts, one is decoding the stream and display and anther is ui layout using opengl and cuda is used to AI.
I don’t want to see the terminal on the screen when before my app run.
If I remove CONFIG_FRAMEBUFFER_CONSOLE. I can see the screen is display a black background before the app runs. It’s fine. But when I run the app, it’s error.


The “graphic” here means the GDM3 or lightdm. Which means if your desktop is already disabled, then it means graphic is disabled.

So could you tell me whether your “graphic” is disabled or not?

AFAIU, you already disabled them since you said:

sudo systemctl set-default

I don’t disable the graphic.
I run “sudo systemctl set-default”.
If I don’t “sudo systemctl set-default”, app can not work on drm.
But when I enable CONFIG_FRAMEBUFFER_CONSOLE, my app and mmapi 08 sample work well.

This command shall already disable gdm… which means your graphic…

But my app work well when I enable CONFIG_FRAMEBUFFER_CONSOLE.
My app work on drm.

Do you remember to unblank the fb before running the app…?