how can i force gsync on on an non compatible freesync monitor ?

i have tried to enable gsync by setting the metamode in the xorg.conf configuration file located under /etc/X11/xorg.conf . I coulnd get it to show up inside the nvidia-settings gui.
Here is gsync mentioned [url][/url]

monitor: LG24MP68VQ
GPU: 1050 ti
distro: linux mint cinnamon

In nvidia-settings GUI’s display configuration you have to click “Advanced…”, then enable “Allow G-SYNC on monitor not validated as G-SYNC Compatible” and apply.

To make it more permanent I use this in my Xorg configuration (needs to be changed depending on output name):

Option         "metamodes" "DP-2: nvidia-auto-select +0+0 {AllowGSYNCCompatible=On}"

nvidia-settings should include it in the config file it can generate.

Is this configuration file valid?

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LG Electronics LG IPS FULLHD"
    HorizSync       30.0 - 85.0
    VertRefresh     40.0 - 75.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1050 Ti"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "HDMI-0: nvidia-auto-select +0+0 {AllowGSYNCCompatible=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24

I saved it under /etc/X11/xorg.conf

nvidia-settings shows that gsync is still disabled. Does Gsync work over HDMI ?

The “metamodes” option line needs to be in the Device section.

To my knowledge G-Sync over HDMI will not work. It’s DisplayPort only.