How can I force omniverse to export/save everything into standard USD

I am having two specific issues:

  • When creating a keyframed animation (e.g. rotation), USD Composer creates a pushgraph instead of setting time sampled data.

  • When Applying textures, they are referenced assets when collected instead of part of the USD scene.

In comparison, when I apply materials and keyframe animation in 3DS Max, then use the 3ds max usd exporter, it puts everything into the single USD file.

  1. You need to bake out the animation to time sampled data, using the STAGE RECORDER. This will write all of your time sampled data out to a separate usd file. Then you can bring it back in as a layer, separate from the actual objects. Then you can use the “save flattened as” to merged the two usd files back to one. Check out this video.
    Omniverse Stage Recorder for Baking Animations (youtube.com)
  2. You can either manually repath the usd file or you can use the “Collect Tool” to collect everything into a local referenced folder. You can even do a “save flattened as” for usd which will further reduce it down to a simple file.

I am trying to use the Collect Tool, with the save flatten option.

Is there something else I should be checking in the menu?
image

It is outputting a usd file and a folder with another usd file and a separate material:

image

Yes that is good, but use the “Save Flattened As” in the main FILE menu.