Import Json file issue

Hello everyone, I need your help to import my json file to blender, in fact, I’m bad with script that’s why I need you.

I’ve tried several script that I found but no one worked for me,

first of all I’ve tried the Maya script that I found on Nvidia assets → blendshape solve
but I’ve this issue

script is here :
import maya.cmds as mc
import json

with open(r’C:\Users\celeb\OneDrive\Documents\Kit\shared\capture\a2f_cache’, “r”) as f:
facs_data = json.loads(
facsNames = facs_data[“facsNames”]
numPoses = facs_data[“numPoses”]
numFrames = facs_data[“numFrames”]
weightMat = facs_data[“weightMat”]
mc.playbackOptions(ast=0, min=0, max=numFrames-1, aet=numFrames-1)

bsNode = 'blendShape1'
for fr in range(numFrames):
    for i in range(numPoses):
        mc.setKeyframe(bsNode+'.'+facsNames[i], v=weightMat[fr][i], t=fr)

And it’s pretty similar with other script, does anyone could help me ?

Thank you very much

Hello, here’s an update,
so i’ve tried to use a script from a video
this one Gina's Mum character test process - YouTube
here is the script

But I still have an issue

Same with blender 3.0 and 2.9

does anyone know why I can’t use this script ?
Thank you a lot

Hello @celeber12! I’ve shared your post with the dev team for further assistance.

Hello! I use the same script Gina’s Mum character test process - YouTube and also had the same problem. Fortunately, I fixed it: Audio2Face exports 46 Blendshapes. The number of Audio2Face Blendshapes must match this line of the script: bs_limit = 46

I hope this helps! :D

oh thank you, it helped, but I don’t have all my blendshape, is it normal ? My jawdrop doesn’t move

but it works in maya with another script but I want to use blender

ok MB, it works, I just change the order of my blendshape, thx a lot again