Imported skeletal meshes are extremely deformed/warped


I am currently trying to port most of my project from UE to USD/Omniverse, but im having some issues with my skeletal meshes. They are nothing fancy, just some random characters with a super basic walking animation made just to add some liveliness to my scene. I know USD does support animations, so i figured it probably wouldnt be too big a deal, but im having some import issues!

First off i tried to import the ones i have in my UE scene, but they turned out… weird (See screenshots attached) so I decided to just download a couple rigged characters from the Asset Store intergrated into the software, since i figured these would probably work and it would give me an opportunity to mess around with the animation graph inside USD composer aswell. Great learning exercise! However, even when importing these ones I have the same issue! What is causing this and how can I fix it? These definitely do not look like people!

Also worth noting only 1 of the 5 different ones i downloaded looks like this. The 4 others are just straight up not showing up. They are in my stage and I can see all the components on the list, but in the actual viewport its just… nothing?


Hi Jon,
You said “just download a couple rigged characters from the Asset Store intergrated into the software”. Is this from the UE store or the Composer Asset Library ? We have character rigs inside of Composer as well. I will pass this along to the Dev Team. Can you send me these characters as a UE file please. You are using the latest UE connector correct ? What version of UE ?

Hi! Apologies for being unspecific, i downloaded these rigged models from the Assets store (beta) inside of USD composer, NOT the UE store. I just noticed I also get an error when i try to place these into my scene. “Mismatched units found on drag and drop, resolved in current authoring layer path/root/rigged_human_character_free”

Yes, I am using the newest UE connector, but I have the same issues with the assets i downloaded through the assets store in USD composer (Believe the model was from sketchfab and the assets store counts as a form of middle-man) and it did not go through UE in this case. I checked the file in blender and it appears fine here (Screenshot attached) so there is something that goes wrong when I try to open it in USD composer.

Assuming its okay if I post the file here, since this model was already available for free through the software :)

Rigged_Human_Character_Free.usdz (2.8 MB)

Hi JonBjornar,
I tried and Unreal Connect can load the usdz you provided without any issue.

I also downloaded this model from actorcore
Both working fine

Hello :) Thank you for trying to help me sort my issue!

It works in UE for me aswell, the problem however, is in USD composer. If I try to place this usdz file into USD composer, it simply will not show up or it will appear as in the images in my original post. It also tells me “Mismatched units found on drag and drop”. I found someone say I could fix this by right clicking on my USD file and hit “edit” and change the “metersbyunit” to match what its set to in my preferences, but this did not resolve my issue


@JonBjornar I wonder if there are some issues with the Metrics Assembler extension in your version of Composer.

Please let us know exactly which version of USD.Composer you are running. You can find this information by going to Help > About. If you right-click on the version text in the dialog it will copy it to your copy/paste buffer.

Also, since you’ve mentioned the Metrics Assembler notifications multiple times, you can configure the Metrics Assembler and even disable it, see the documentation here: Metrics Assembler — Omniverse Extensions latest documentation

Thanks for working with us on this issue!

Hello! This is the version I am currently running.

USD.Composer 2023.1.1-rc.1
Omniverse Kit
Client Library Version: 2.32.0-release.4682+tc.9a1808da
USD Resolver Version: 1.27.0-release.3896+tc.fa0c4962
USD Version: 22.11.nv.0.2.955.d3c752d9-win64_py310_release-kit-release-integ-23-04-105-0-0
MDL SDK Version: Iray RTX 2022.1.7, build 363600.4887

It appears that this is the issue, i just launched an older version of the software and the meshes worked as intended!

I will attach a couple of screenshots underneath comparing the 2 versions aswell. As you can see in the version working correctly, the mesh I exported from UE myself is still looking a bit weird, but that is probably just some issues with the skeleton being imported in the wrong order as I expected, i actually got the actual model this time, some bodyparts are just being stretched the wrong ways!

And then in the newest version, the model is definitely not looking like a person, while the ones i downloaded pre-made doesnt even show up in the first place, completely blank. So this is definitely a problem with the version I am using, which is the one I linked above!

Thank you

This is the older version of the software (2022.3.1)

And this is the new version linked above

can you please go to Edit-Preferences->Metrics Assembler and change the default setting to Ask to resolve?
Then you should see what units divergency was found and we can see if something is wrong with the metrics assembler logic itself.

You can eventually disable it completely in the same preferences.


I changed it to “Ask to resolve” and it gave me this warning.


Thanks for the help

Ok so a rotation correction should have been applied only, the meters per unit are the same. So if you cancel (or set the metrics assembler to disabled) does it fix the issue?

Neither disabling the metrics assembler or cancelling the popup fixes the issue, the imported mesh is still completely blank in this version of the software. If i use the older version I have no issues

Thanks for checking, then the metrics assembler is just a red herring. @LouRohan any other ideas what to try to figure out the issue?