Installing SDK components on AGX Orin


I was trying to update my Jetson AGX Orin to 5.02 and I failed.
That made my device broken.
So I need to reflash my device using SDK manager.
(The host PC is ubuntu 20.04.5 LTS and The Jetpack I’d like to install is latest version.)

I succeeded to reflash my device (I chosed manual setup to put my Jetson target into Force Recovery Mode) but I can’t install SDK components.
I uploaded The screen the host PC shows.

After I set the proxy configuration on the Jetson, I tried to start install with Jetson showing desktop on its screen but because the host PC didn’t detect the Jetson, I turned the device to force recovery mode.
So, the host PC recognized the device. (I checked it by lsusb)
After that I entered Jetson’s username and passward and I pushed the install batton but I failed.
The host PC shows that Default ip is not available. Please make sure the default ip is shown in ip addr, or use a customer ip instead.
As a supplementary explanation, the jetson is connected to the host PC through USB and the host PC is connected to internet through Ethernet.
In this situation, what should I do to complete the install?

Additional information
I found that the boot appearence is deferent from previous system.
I added the video.

Thank you.

Are you able to locally log in to the Jetson? If so, what do you see from this on both the Jetson and the Orin:

ip -s addr show
ip -s route show

Also, when the Jetson is fully booted, but the USB cable is not yet plugged in, monitor “dmesg --follow” on the host PC. Then plug in the USB, and post what logs show up. Quite often networking is working well, but the host PC needs to be told it is ok to allow the virtual USB network device. The log should say a lot if the Jetson is fully up and running at the moment you plug in the USB (we’re only interested in the part of the log which appears as a result of the USB plugin).

Hello, linuxdev.

I tried “ip -s addr show” and “ip -s route show” on Jetson AGX Orin.
I upload the result.
ip (2.9 KB)

And I monitered “dmesg --follow” on the host, while I connected Jetson and the host PC through USB with Jetson running but nothing was added on the command prompt.

Thank you


I connected jetson to internet through the ethernet and checked the ip by ifconfig.
So I entered the ip , username and password on the host PC.
The host PC showed “cannot connect to the device via SSH. check the user name and password. and make sure that SSH service is running on device”.

And I found the host PC doesn’t detect the device.

sorry for the consecutive asking.

Can the host detect the Jetson with Jetson running ( in the situation I can operate the jetson )?

We will need the output of either “ifconfig” or “ip -s addr show”, plus either “route” or “ip route show” from both Jetson and PC. However, the Jetson info showed there was no wired (or Wi-Fi, but we aren’t dealing with Wi-Fi) setup at all. Is the wired ethernet plugged in to a router? If it were, then I would have expected to see at least a few bytes of traffic from a DHCP negotiation. This includes lack of setup to the virtual USB network device, but I am wondering why eth0 had no traffic at all. How is this wired? Can you give details of where switches and routers are located?

Thank you for your kind help.

Actually, I posted the other question simultaneously.
A moderator said that the device has the hardwear problem and I need RMA.
So, I don’t need to solve the problem I posted in this topic.

Thank you for your time.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.