Interface Camera with AGX Orin

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)
DRIVE OS 6.0.4 SDK
other

Target Operating System
Linux
QNX
other

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)
other

SDK Manager Version
1.9.1.10844
other

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers
other

Hi,

I am facing issue is setting interface with Entron F008A120RM0A.

I tried port A0 & C0 in both case i got same error:

using this cmd from :

./nvsipl_camera --platform-config “F008A120RM0A_CPHY_x2” --link-enable-masks “0x0000 0x0000 0x0001 0x0000” --showfps -d

or

./nvsipl_camera --platform-config “F008A120RM0A_CPHY_x4” --link-enable-masks “0x0000 0x0000 0x0001 0x0000” --showfps -d

error:

nvsipl_camera: ERROR: INvSIPLQuery::GetPlatformCfg failed. status: 1

How, i can set GetPlatformCfg?

also, could you confirm if camera in use is supported by AGX Orin when only one camera is used on port C.

under help in putty : it shows only these Entron config supported.

F008A120RM0A_CPHY_x2 :F008A120RM0A 24BIT RGGB module in 2 lane CPHY mode
F008A120RM0A_CPHY_x2_TPG :F008A120RM0A 24BIT RGGB module in 2 lane CPHY, TPG mode
F008A120RM0A_CPHY_x4 :F008A120RM0A 24BIT RGGB module in 4 lane CPHY mode
F008A120RM0A_CPHY_x4_TPG :F008A120RM0A 24BIT RGGB module in 4 lane CPHY, TPG mode

Please suggest, how this could be resolved?

Please refer to the commands for the same camera module used by the developer at wfdCreateDevice failed on drive agx orin.
I presume they worked for him after resolving the gdm issue.

We will check the document issue internally. Thanks.

manage to resolve this, got the updatted document with right cmd.

Thanks for keeping us in the loop. If you can share the successful command or which doc version helped, that would be great!