Isaac Sim/gym deformable Physics

Hey, I’m trying to work with deformable bodies in Isaac Sim and use that for RL using OmniIsaacGym.

As it can be seen in the first video, it follows the necessary deformable physics as needed in the USD file when viewing it in Isaac Sim.

But when I’m trying to import the same USDA file programmatically in the OmniIsaacGym code, it can be seen that the deformable physics are not quite applied here. The object is seen to be floating, instead of falling down due to gravity. Also, the object does not seem to have any type of collision properties, i.e., if I move the object (while Playing so that physics are applied), it travels inside of the table or robot, indicating no collision properties. This does not apply in the first video when I’m viewing the same USDA file in Isaac Sim.

Furthermore, I checked the /physicsScene to have the enable_gpu_dyanmics as True/enabled.

Kindly help. I’m using the franka-skrl example as the base for my code. do you have any opinion on this?


Hi there, if you are using the cloner in OmniIsaacGymEnvs, please ensure replicate_physics is set to False when calling the cloner. Deformable bodies are currently not supported by physics replication.

Hey kelly,

Thanks for the reply. I tried setting the replicate_physics as False in the which is where I’m calling the cloner. The object is still seen floating. I clicked on the mesh and still see deformable body physics applied to it. Not sure why it doesn’t fall down.

Can you verify there are no fixed joints applied to the object? Or any other additional physics attributes/parameters that shouldn’t be applied to it? You can check this information from the details panel in the UI.


I did check, and found no fixed joint or any parameters associated with it.
I have added the files I have used in this thread for more context.
chickenLeg_deformable_2.usda (2.4 MB)
grip_rl_deformable.usda (2.0 MB)

Hi there, thanks for verifying! It seems like we have a bug with deformable simulation using the GPU pipeline. The issue has been fixed internally and will be available in the next Isaac Sim release. For now, you can add the following lines after creating the World and before starting simulation to bypass the issue:

import carb
carb.settings.get_settings().set_bool("/physics/suppressReadback", False)

Got it. Thanks, I’ll give that a try. Just curious, when you guys mentioned the next release, is that 2022.2.1? or the release after that?

It will be in the release after 2022.2.1, some time around June this year.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.