Isaac Sim: stderr maxBuffer length exceeded

I am trying to install Isaac Sim 2021.2.1 using the Omniverse launcher. After Downloading and during the install the launcher returns the error “Error occurred during installation of Isaac Sim: stderr maxBuffer length exceeded”. The important section of the logs states:

[2022-05-20 20:28:44.685] [debug] Reset current installer.
[2022-05-20 20:28:44.686] [debug] [186dda2b-04f0-4a47-afed-bfe9616c317f] Removing the artifact path /home//.local/share/ov/pkg/isaac_sim-2021.2.0/Isaac due to an error.
[2022-05-20 20:28:45.206] [debug] [186dda2b-04f0-4a47-afed-bfe9616c317f] Removing the installation path /home/
/.local/share/ov/pkg/isaac_sim-2021.2.0 due to an error.
[2022-05-20 20:28:45.837] [debug] [186dda2b-04f0-4a47-afed-bfe9616c317f] Failed to remove the installation path /home//.local/share/ov/pkg/isaac_sim-2021.2.0: Error: ENOTEMPTY: directory not empty, rmdir '/home//.local/share/ov/pkg/isaac_sim-2021.2.0/exts/omni.kit.profiler.window-1.3.1+cp37/omni/kit/profiler/window’
[2022-05-20 20:28:45.837] [error] RangeError [ERR_CHILD_PROCESS_STDIO_MAXBUFFER]: stderr maxBuffer length exceeded
at new NodeError (node:internal/errors:371:5)
at Socket.onChildStderr (node:child_process:492:14)
at Socket.emit (node:events:390:28)
at addChunk (node:internal/streams/readable:315:12)
at readableAddChunk (node:internal/streams/readable:285:11)
at Socket.Readable.push (node:internal/streams/readable:228:10)
at Pipe.onStreamRead (node:internal/stream_base_commons:199:23)

Any help you could provide would be greatly appreciated.

Many Thanks!

1 Like

Hi, did you solve this?

Hi @eliabntt94

I didn’t, I had to wait for the next release and that solved the error for me.

I solved by installing the suggested nvidia drivers. I was on 525.80 went back to ?.60? (I’m not at my workstation)

1 Like

What you can do to debug it is commenting the last couple of lines of ( especially) during installation. That is the last step, so if that script run successfully, you will have everything installed.
At that point you can manually run those commands ( and see precisely what fails.

In my case it was messing with cuda, started printing error messages, that filled python buffer, that triggered the error.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.