Issue #200327384 - WiFi Ad-Hoc networking is not supported and may cause a system crash if enabled.

Creating a specific topic for this problem so that a resolution and/or workarounds can be shared.

The original exchange can be found here: https://devtalk.nvidia.com/default/topic/1019640/jetson-tx2/jetpack-3-1-mdash-l4t-r28-1-released-for-jetson-tx1-tx2/post/5210354/#5210354

Summary:
It was first publicly documented in the R28.1 release notes:
http://developer2.download.nvidia.com/embedded/L4T/r28_Release_v1.0/Docs/Tegra_Linux_Driver_Package_Release_Notes_R28.1.pdf Page 13.

When configuring the wireless card to operate in Ad-Hoc (IBSS) mode using encryption WEP or WPA, the system would crash. However, if configured to not use an encryption key the Ad-Hoc mode would work without crashing.
The problem was not present on the previous JetPack driver release (27.1) and TX2 units running R27.1 can utilize all supported encryption modes while in Ad-Hoc (IBSS) mode.

Unfortunately, some carrier-board support packages require R28.1 so it is not possible to revert to 27.1 to get around this problem.

If there are any updates on a solution, please share them here.

Hi hgreen,

I am sorry that this issue occurred due to the new firmware. If you need a quick solution, you can also contact the wifi chip vendor.

hi @hgreen,
Can you please let me know the commands on how to create ad-hoc network in JetPack driver release (27.1) and TX2?

I tried in 28.1 but its failed:
nvidia@tegra-ubuntu:~ sudo iwconfig wlan0 mode ad-hoc essid test-adhoc Error for wireless request "Set Mode" (8B06) : SET failed on device wlan0 ; Invalid argument. nvidia@tegra-ubuntu:~

I downgraded the tx2 to Jetpack 3.0 + 27.1 CLI, but still the issue persists.

Can you please let me know how did you create ad-hoc network in 27.1 + jetpack 3.0?

Thanks in advance,
MJ

You can use

iw dev wlan0 ibss join ...

or configure it via wpa_cli. If you try to specify a key on 28.1 the system will crash.

I’m coming at a point where I’l have to connect to some devices in an Ad-hoc wifi network and thus feel concerned by this bug.

@hgreen,
Have you contacted the wifi chip vendor ? Any fixed version released or planned ?

@WayneWWW,
Is there some patch to get the old firmware working with L4T R28.1 ?
If yes, would you please let us know how to get this old firmware and installing it ?

Thanks for sharing,
HP

No, who is the wifi chip vendor? My thought was since NVIDIA was the one who initially documented this problem in the R28.1 release notes that they would take the lead to resolve it. I’m able to continue with my use of the TX2 without encryption on the IBSS mode for now.

Thanks for sharing this, but no encryption is not affordable out of the lab… :-(

I still expect a workaround or a planned fix.
Seems it is a Broadcom chip (BCM 4354), but I agree that NVIDIA should know much more than us about this (I don’t know any details of Issue #200327384).

Hi Honey_Patouceul,

Just checked internally. Since Ibss is not part of WiFi supported modes in Jetson release documents, we don’t have the fix for this issue.

WiFi firmware in Jetson release underwent FCC certification, so fw cannot be changed.

Does anybody successfully set the TX2’s (R28.2 ) WIFI work in ad-hoc mode??

ad-hoc is still not in support list on rel-28.2. Sorry for inconvenience.

I’d further advise not to try it…I tried once, it was crashing during boot of Linux and rebooting, no way to take control again…I’ve had to make an image of my Jetson eMMC on host, loop mount it for fixing wifi mode and reflash my Jetson with fixed image. So, unless you have a few hours to waste…

Is the R28.2 version not support the ad-hoc mod nor the wifi module in the TX2 not support ?

365953468,

Sorry that it is still not supported. There was some fw problem so we disabled it anyway.

You could contact broadcom to see if they have fixed this issue or not.

Hi
You mean there is a problem in the WIFI chip in the TX2 board. If I try to use a another wifi chip, will ad-hoc mode can be used?

Yes, if you use other wifi chip, it may work.

configure it via wpa_cli. If you try to specify a key on 28.1 the system will crash.

I have two TX2 boards with L4T R32.3.1 and I’m trying to connect in ad-hoc mode. I’m able to connect without encryption but I can’t ping any device from the other. It says destination host unreachable. Here’s a pic from both devices:


Any help is much appreciated.

EDIT: I tried updating to L4T 32.4.3 and the problem still persists. Come on anybody?

Hi 93afandi,

Please help to open a new topic. Thanks