unable to create ad-hoc mode in jetson tx2

Hi,
I am trying to create ad-hoc mode in wlan0 on the Jetson TX2.
I tried it in first Jetpack 3.1 + LRT r28.1, it was showing following error:

nvidia@tegra-ubuntu:~ sudo iwconfig wlan0 mode ad-hoc essid test-adhoc Error for wireless request "Set Mode" (8B06) : SET failed on device wlan0 ; Invalid argument. nvidia@tegra-ubuntu:~

The I found in release notes of LRT 28.1, it does not support ad-hoc mode, so I switched to Jetpack 3.0 + LRT r27.1, but it has also the same issue.

can you please help me to figure out whats the problem is?

here is the output of ifconfig and iwconfig:
nvidia@tegra-ubuntu:~$ ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 00:04:4b:8c:af:f4
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

nvidia@tegra-ubuntu:~ nvidia@tegra-ubuntu:~ iwconfig
lo no wireless extensions.

dummy0 no wireless extensions.

wlan0 no wireless extensions.

eth0 no wireless extensions.

nvidia@tegra-ubuntu:~$

Thanks,
MJ

Hi MJ, please see the L4T Release Notes, section 3.3, which states that ad-hoc mode isn’t supported.

Access Point (AP) infrastructure mode is working however (see section 2.6). You should still be able to follow this procedure to enable it.

Hi,
The release note is for 28.1, I did saw it earlier, that’s why I moved to 27.1 where the issue still persists.
I could not find any such info in 27.1 release notes.

Can you please confirm whether ad-hoc mode is supported in 27.1 or not?

Thanks,
MJ

Were you able to try the information from this post?

https://devtalk.nvidia.com/default/topic/1024189/jetson-tx2/issue-200327384-wifi-ad-hoc-networking-is-not-supported-and-may-cause-a-system-crash-if-enabled-/post/5212876/#5212876

The user confirmed they were able to use ad-hoc in open mode, or without encryption.

yes, I am following that thread too.
I checked with connect-tech customer service and they confirmed the ad-hoc mode is not supported for now.

Hi, I want to know whether the jetpack3.2 system support wifi ad-hoc mode?
I used to config the local wifi module in tx2 in ad-hoc mode, but this mode doesn’t work. So I try to use a rtl8188eu wifi module to config as the ad-hoc mode, but it does’t work too. (The rtl8188eu module can’t work as ad-hoc mode in other platform like xu4)