Issues installing Modulus extension in Create

Hello I am trying to install the modulus extension on Create 2022.1.3, I am running Ubuntu 22.04 with a 3080Ti grapics card. Driver version 510.73.05 CUDA version 11.6

After clicking on the install button this is the output of the Create console before it crashes.

2022-06-17 20:37:22 [169,667ms] [Info] [] [169.741s] Async pulling extension: modulus_ext.core-22.3.1 from the registry.
2022-06-17 20:37:22 [169,667ms] [Info] [omni.kit.registry.nucleus.utils] [omni.kit.registry.nucleus]: [kit/public] pull extension: modulus_ext.core-22.3.1+lx64.r.cp37 in ‘/home/waverider/.local/share/ov/data/Kit/Create.Next/2022.1/exts/3’
2022-06-17 20:37:22 [169,667ms] [Info] [omni.kit.registry.nucleus.utils] [omni.kit.registry.nucleus]: [kit/public] modulus_ext.core-22.3.1+lx64.r.cp37 is not in cache: ‘/home/waverider/.cache/ov/exts/3’
2022-06-17 20:37:22 [169,668ms] [Info] [omni.kit.registry.nucleus.utils] [omni.kit.registry.nucleus]: (find archive) check exists, omni.client.stat:
2022-06-17 20:37:22 [169,670ms] [Info] [omni.kit.registry.nucleus.utils] [omni.kit.registry.nucleus]: result: Result.OK
2022-06-17 20:37:22 [169,670ms] [Info] [omni.kit.registry.nucleus.utils] [omni.kit.registry.nucleus]: downloading: ‘’ → ‘/tmp/tmp2pe7fm0p/’…
2022-06-17 20:37:22 [169,670ms] [Info] [] [py stdout]: [omni.kit.registry.nucleus]: [omni.kit.registry.nucleus]: downloading: ‘’ → ‘/tmp/tmp2pe7fm0p/’…

2022-06-17 20:37:22 [169,670ms] [Info] [omni.kit.registry.nucleus.utils] [omni.kit.registry.nucleus]: (downloading ext archive) copying: → /tmp/tmp2pe7fm0p/

Thank you!

Hello @robert34ck2! Thanks for posting your issue here. I will send this over to the dev team for some help!

feel free to let me know if there’s any additional info y’all might need from me

Hi Robert! Is there any chance you could try the following:

  • in ~/.nvidia-omniverse/config/omniverse.toml, add the following lines:
  • Start Create and attempt to install the extension again
  • Provide the full log here (the location of the log file is usually printed right after Create is started)

well i tried to reinstall and it worked, not sure what changed. I’m guessing it was an issue with reaching the S3 bucket where the plugin was located?

anyways, now i’m having issues with the fpga modulus plugin…i’ll make a separate post about it