J502JTAG short circuit damaged carrier board


I’m from a robotics team from Greece. On our robotic platform we use a Jetson AGX Xavier Development Kit.

Unfortunately yesterday, while we were placing the Jetson back to our platform something went wrong and when we tried to boot smoke came up.

Upon further inspection we found some pins from J502JTAG bent and created a short circuit that blew up what we think is the U504.

We used a multimeter in continuity mode and found that some of the bent pins from J502JTAG were connected to the chip that was smoking. After bending the J502JTAG pins back to the normal place we tried to boot again but our Jetson didn’t POST. Thankfully smoke didn’t come up this time.

I’m attaching a photo that will help you understand better what happened.

I also have three (3) questions:

  1. Can you identify that the burned chip is actually U504 and give us the full name of the burned chip in order for us to try and replace it? We think U504 is actually APW7307AZI-TRG but a confirmation would be nice.

  2. Do you know if this could have damaged our compute module? Because we’re thinking about buying a new carrier module and we’re weighing our options. I mean, if we have to buy a new carrier and then it turns out our computing module is damaged too we might as well buy a new Jetson.

  3. Are there any suggestions you can make about our situation?

Thank you in advance.


Hi, it is U504. The pin 1 of J502 is VDD_1V8, the VDD_1V8 is from U504 (APW7307AZI-TRG, DC/DC converter). So U504 might be damaged by the shorting b/w pin 1 of J502 to GND. In general, module won’t be damaged by this, you can try removing U504 and unplugging all peripheral devices to check if it can power on. But you need to note that VDD_1V8 is one of supplies to the HDMI HPD level shift and to the debug FTDI chip. You can get detail info from carrier board (P2822) schematic and PCB/assembly file in Xavier carrier board design file package in DLC.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.